aboutsummaryrefslogtreecommitdiff
path: root/net/pptpclient
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-11-20 21:49:25 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-11-20 21:49:25 +0000
commit0055c9ec1472f01d1be2699d8eaeba031d0a8fe3 (patch)
treee3e73e938a4a6f1e83f9c56bbcb256e656bb6bc2 /net/pptpclient
parentcc631bb7ad48bc4375fee29730b22efb12b26c1f (diff)
downloadports-0055c9ec1472f01d1be2699d8eaeba031d0a8fe3.tar.gz
ports-0055c9ec1472f01d1be2699d8eaeba031d0a8fe3.zip
- Revert last changes, that cause port broken.
PR: ports/140432 Noticed by: Matthew Luckie <mjl@luckie.org.nz>
Notes
Notes: svn path=/head/; revision=244562
Diffstat (limited to 'net/pptpclient')
-rw-r--r--net/pptpclient/Makefile25
1 files changed, 6 insertions, 19 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index 219d6e6b9e97..f27d4d99526e 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pptpclient
PORTVERSION= 1.7.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/pptp/pptp-${PORTVERSION}
DISTNAME= pptp-${PORTVERSION}
@@ -17,28 +17,15 @@ COMMENT= PPTP client for establishing a VPN link with an NT server
USE_PERL5= yes
-MAN8= pptp.8 pptpsetup.8
-FILES= README ppp.conf
-PORTDOCS= AUTHORS COPYING ChangeLog DEVELOPERS INSTALL NEWS \
- PROTOCOL-SECURITY README TODO USING
+MAN8= pptp.8
MAKE_ARGS= DEBUG=""
-post-patch:
- ${REINPLACE_CMD} -e 's|/usr|/usr/local|g' -e 's|/etc|/usr/local/etc|g' \
- ${WRKSRC}/Makefile
- ${REINPLACE_CMD} 's|/etc|/usr/local/etc|g' ${WRKSRC}/pptpsetup
-
do-install:
- ${MKDIR} ${EXAMPLESDIR} ${ETCDIR}
${INSTALL_PROGRAM} ${WRKSRC}/pptp ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKSRC}/pptpsetup ${PREFIX}/sbin
- ${INSTALL_MAN} ${MAN8:S,^,${WRKSRC}/,} ${MAN8PREFIX}/man/man8
- ${INSTALL_DATA} ${FILES:S,^,${FILESDIR}/,} ${EXAMPLESDIR}
- ${CP} ${FILESDIR}/ppp.conf ${ETCDIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ ${MKDIR} ${PREFIX}/share/examples/pptpclient
+ ${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/pptpclient
+ ${INSTALL_DATA} ${FILESDIR}/ppp.conf ${PREFIX}/share/examples/pptpclient
+ ${INSTALL_MAN} ${WRKSRC}/pptp.8 ${PREFIX}/man/man8
.include <bsd.port.mk>