aboutsummaryrefslogtreecommitdiff
path: root/net/proxy-suite
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-10-19 15:52:02 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-10-19 15:52:02 +0000
commit1e2d710bb99c6ef1b6e7a8b70c4af208fcc7a9a7 (patch)
tree4ec5d260afe5952bf9cbe04e7dbeed34958d517e /net/proxy-suite
parente9aeb747060a8bff587763d5938fd5c6195e1bef (diff)
downloadports-1e2d710bb99c6ef1b6e7a8b70c4af208fcc7a9a7.tar.gz
ports-1e2d710bb99c6ef1b6e7a8b70c4af208fcc7a9a7.zip
- Add suport LDAP
- Add pkg-message - Bump PORTREVISION PR: 31351 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=48950
Diffstat (limited to 'net/proxy-suite')
-rw-r--r--net/proxy-suite/Makefile31
-rw-r--r--net/proxy-suite/files/patch-cf11
-rw-r--r--net/proxy-suite/files/patch-regex18
-rw-r--r--net/proxy-suite/pkg-descr5
-rw-r--r--net/proxy-suite/pkg-message4
-rw-r--r--net/proxy-suite/pkg-plist3
6 files changed, 49 insertions, 23 deletions
diff --git a/net/proxy-suite/Makefile b/net/proxy-suite/Makefile
index 28acbcb80461..32e27054b614 100644
--- a/net/proxy-suite/Makefile
+++ b/net/proxy-suite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proxy-suite
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.suse.com/pub/projects/proxy-suite/src/ \
ftp://ftp.crc.ca/pub/systems/linux/suse/projects/proxy-suite/src/ \
@@ -15,11 +16,37 @@ MASTER_SITES= ftp://ftp.suse.com/pub/projects/proxy-suite/src/ \
MAINTAINER= thomas@cuivre.fr.eu.org
-CONFIGURE_ARGS= --with-libwrap=/usr/lib/
-
USE_AUTOCONF= yes
USE_GMAKE= yes
+#
+# basic configure args
+#
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-libwrap=/usr/lib --with-regex \
+ --sysconfdir=${PREFIX}/etc/proxy-suite \
+ --localstatedir=/var/run \
+ --enable-warnings --enable-so-linger --enable-rfc1579 \
+ --disable-proc-mods
+
+#
+# OPTIONAL: include ldap-support - currently ldap.2 needs minor fixes...
+#
+.if defined(WITH_LDAP)
+CONFIGURE_ARGS+= --with-libldap
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap
+.else
+CONFIGURE_ARGS+= --without-libldap
+.endif
+
+#
+# OPTIONAL: re-build the sgml documentation (postscript, html)
+# unfortunatenly this docu it is not up to date :-((
+# reading of the manual pages and HOWTO's makes more sense...
+#
+.if !defined(WITH_SGMLDOC)
+ALL_TARGET= -C ftp-proxy
+.endif
+
MAN8= ftp-proxy.8
MAN5= ftp-proxy.conf.5
diff --git a/net/proxy-suite/files/patch-cf b/net/proxy-suite/files/patch-cf
new file mode 100644
index 000000000000..1f17e63ca90d
--- /dev/null
+++ b/net/proxy-suite/files/patch-cf
@@ -0,0 +1,11 @@
+--- ftp-proxy/Makefile.in
++++ ftp-proxy/Makefile.in Tue Jun 26 01:12:06 2001
+@@ -55,7 +55,7 @@
+ PROC_FTP= @PROC_FTP@
+
+ CONF_SRC= ftp-proxy.conf.sample
+-CONF_DST= $(ETC_DIR)/ftp-proxy.conf
++CONF_DST= $(ETC_DIR)/ftp-proxy.conf.sample
+
+ FTP_MAN5= ftp-proxy.conf.5
+ FTP_MAN8= ftp-proxy.8
diff --git a/net/proxy-suite/files/patch-regex b/net/proxy-suite/files/patch-regex
deleted file mode 100644
index 561e0dd2d4be..000000000000
--- a/net/proxy-suite/files/patch-regex
+++ /dev/null
@@ -1,18 +0,0 @@
---- ftp-proxy/ftp-cmds.c.orig Fri Feb 11 15:23:59 2000
-+++ ftp-proxy/ftp-cmds.c Fri Feb 11 15:25:33 2000
-@@ -371,6 +371,7 @@ static void cmds_user(CONTEXT *ctx, char
- for (cmd = cmdlist; cmd->name != NULL; cmd++) {
- if (strcasecmp("USER", cmd->name) != 0)
- continue;
-+#if defined(HAVE_REGEX)
- if (cmd->regex == NULL)
- break;
- if ((p = cmds_reg_exec(cmd->regex, arg)) != NULL) {
-@@ -383,6 +384,7 @@ static void cmds_user(CONTEXT *ctx, char
- ctx->cli_ctrl->peer, p);
- return;
- }
-+#endif
- break;
- }
-
diff --git a/net/proxy-suite/pkg-descr b/net/proxy-suite/pkg-descr
index 33e3adaae21f..67131442b3a2 100644
--- a/net/proxy-suite/pkg-descr
+++ b/net/proxy-suite/pkg-descr
@@ -2,7 +2,7 @@ The SuSE Proxy-Suite, a set of programs to enhance firewall security.
The first (and currently only) component being released is the FTP-Proxy.
* Securely relays FTP connections between clients and servers
-* Can switch connections from active to passive and vice versa
+* Can switch connections from active to passive and vice versa
* Utilizes port ranges for both control and data connections
* Provides extensive auditing (via syslog or rotating log files)
* Can separate user related from system triggered audit events
@@ -15,7 +15,8 @@ The first (and currently only) component being released is the FTP-Proxy.
* Planned to support RFC 2428 (IPv6 Extensions for FTP)
* Based on GNU AutoConf, supposed to run on many UNIX systems
-Ported to FreeBSD using OpenBSD port by Camiel Dobbelaar <cd@sentia.nl>
+Ported to FreeBSD using OpenBSD port by Camiel Dobbelaar <cd@sentia.nl>,
+with updates contributed by Marius Tomaschewski <mat@mt-home.net>.
WWW: http://www.suse.de/en/support/proxy_suite/
diff --git a/net/proxy-suite/pkg-message b/net/proxy-suite/pkg-message
new file mode 100644
index 000000000000..043e828b4a18
--- /dev/null
+++ b/net/proxy-suite/pkg-message
@@ -0,0 +1,4 @@
+ This port provides a sample configuration file as
+ PREFIX/etc/proxy-suite/ftp-proxy.conf.sample
+ Please copy this file to ftp-proxy.conf and edit
+ to fit your needs. Default PREFIX is /usr/local.
diff --git a/net/proxy-suite/pkg-plist b/net/proxy-suite/pkg-plist
index 3d77e7048be5..0f3300c8df5f 100644
--- a/net/proxy-suite/pkg-plist
+++ b/net/proxy-suite/pkg-plist
@@ -1,2 +1,3 @@
sbin/ftp-proxy
-etc/ftp-proxy.conf
+etc/proxy-suite/ftp-proxy.conf.sample
+@dirrm etc/proxy-suite