aboutsummaryrefslogtreecommitdiff
path: root/net/pvm++
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 13:38:32 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 13:38:32 +0000
commitf004bf7ce17bb8700f07832c6b78ac649bdb3221 (patch)
tree3f4cd9d60ab9258e2696139f4a030495ec6e98f7 /net/pvm++
parent088118876dc9c1f5799bd2bfe25a46fc3bce39b9 (diff)
downloadports-f004bf7ce17bb8700f07832c6b78ac649bdb3221.tar.gz
ports-f004bf7ce17bb8700f07832c6b78ac649bdb3221.zip
- GNU_CONFIGURE -> USE_LIBTOOL
PR: 46465 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=71786
Diffstat (limited to 'net/pvm++')
-rw-r--r--net/pvm++/Makefile12
-rw-r--r--net/pvm++/files/patch-configure10
-rw-r--r--net/pvm++/pkg-plist3
3 files changed, 19 insertions, 6 deletions
diff --git a/net/pvm++/Makefile b/net/pvm++/Makefile
index 1c7403f86b76..456443177d8b 100644
--- a/net/pvm++/Makefile
+++ b/net/pvm++/Makefile
@@ -8,6 +8,7 @@
PORTNAME= pvm++
PORTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= net parallel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://pvm-plus-plus.sourceforge.net/pub/%SUBDIR%/ \
@@ -16,16 +17,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S:+:-plus:g}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/bin/pvm:${PORTSDIR}/net/pvm
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpvm3.a:${PORTSDIR}/net/pvm
-GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-pvm-incs=${LOCALBASE}/include \
+ --with-pvm-libs=${LOCALBASE}/lib
INSTALLS_SHLIB= yes
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/pvm++
- @${CP} ${WRKSRC}/doc/*.png ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/pvm++
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.png ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/net/pvm++/files/patch-configure b/net/pvm++/files/patch-configure
new file mode 100644
index 000000000000..5c02d4c54417
--- /dev/null
+++ b/net/pvm++/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Jun 27 22:23:51 2001
++++ configure Sat Dec 14 09:02:22 2002
+@@ -5296,6 +5296,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/net/pvm++/pkg-plist b/net/pvm++/pkg-plist
index b47f567e2556..21e43658f82e 100644
--- a/net/pvm++/pkg-plist
+++ b/net/pvm++/pkg-plist
@@ -18,9 +18,7 @@ include/pvm++/task.hh
include/pvm++/task.ii
include/pvm++/taskset.hh
include/pvm++/types.hh
-@dirrm include/pvm++
lib/libpvm++.a
-lib/libpvm++.la
lib/libpvm++.so
lib/libpvm++.so.1
share/aclocal/pvm++.m4
@@ -42,3 +40,4 @@ share/aclocal/pvm++.m4
%%PORTDOCS%%share/doc/pvm++/icon1.png
%%PORTDOCS%%share/doc/pvm++/icon2.png
%%PORTDOCS%%@dirrm share/doc/pvm++
+@dirrm include/pvm++