aboutsummaryrefslogtreecommitdiff
path: root/net/py-libdnet
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-03-12 17:51:53 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-03-12 17:51:53 +0000
commit1b20ff5d483e1a83209923b8b7d3448a81886c47 (patch)
treeb5da645b04d39671978903f6b572d1adde366feb /net/py-libdnet
parentca7c55e010ea88428028578bd479fdd1d3b3a203 (diff)
downloadports-1b20ff5d483e1a83209923b8b7d3448a81886c47.tar.gz
ports-1b20ff5d483e1a83209923b8b7d3448a81886c47.zip
Fix py-libdnet.
The py-libdnet port has been seperated out as a slave port to libdnet and is now dependent on libdnet. py-libdnet now only installs the libdnet python module. Since files previously owned by py-libdnet are now owned by its dependency, in order to upgrade correctly, py-libdnet must be deinstall and then reinstalled manually. PR: 109262 Submitted by: thierry and me Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=187216
Diffstat (limited to 'net/py-libdnet')
-rw-r--r--net/py-libdnet/Makefile24
-rw-r--r--net/py-libdnet/pkg-descr8
-rw-r--r--net/py-libdnet/pkg-plist1
3 files changed, 27 insertions, 6 deletions
diff --git a/net/py-libdnet/Makefile b/net/py-libdnet/Makefile
index 90a72a28d1e6..e0ac15d5e5d9 100644
--- a/net/py-libdnet/Makefile
+++ b/net/py-libdnet/Makefile
@@ -5,17 +5,29 @@
# $FreeBSD$
#
+CATEGORIES= net python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
COMMENT= Python module for libdnet
-BROKEN= Incomplete pkg-plist
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2007-04-10
+LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
+
+NOT_FOR_ARCHS= ia64
+NOT_FOR_ARCHS_REASON_ia64= fails to build with internal compiler error
MASTERDIR= ${.CURDIR}/../libdnet
+INSTALL_WRKSRC= ${WRKSRC}/python
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
-BUILD_PYTHON_MODULE= yes
+LIBDNET_SLAVE= yes
-NOT_FOR_ARCHS= ia64
-NOT_FOR_ARCHS_REASON_ia64= fails to build with internal compiler error
+USE_PYTHON= yes
+CONFIGURE_ARGS= --with-python
+
+.if defined(MAINTAINER_MODE)
+regression-test: install
+ ${PYTHON_CMD} ${INSTALL_WRKSRC}/test.py
+.endif
.include "${MASTERDIR}/Makefile"
diff --git a/net/py-libdnet/pkg-descr b/net/py-libdnet/pkg-descr
new file mode 100644
index 000000000000..d2c164de959f
--- /dev/null
+++ b/net/py-libdnet/pkg-descr
@@ -0,0 +1,8 @@
+Python wrapper around libdnet which provides a simplified, portable
+interface to several low-level networking routines, including network
+address manipulation, kernel arp(4) cache and route(4) table lookup and
+manipulation, network firewalling, network interface lookup and
+manipulation, and raw IP packet and Ethernet frame transmission. It is
+intended to complement the functionality provided by pcap(3).
+
+WWW: http://libdnet.sourceforge.net/
diff --git a/net/py-libdnet/pkg-plist b/net/py-libdnet/pkg-plist
new file mode 100644
index 000000000000..517b2c4e10a4
--- /dev/null
+++ b/net/py-libdnet/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/dnet.so