aboutsummaryrefslogtreecommitdiff
path: root/net/py-magic-wormhole/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-07-03 04:12:55 +0000
committerSteve Wills <swills@FreeBSD.org>2016-07-03 04:12:55 +0000
commit4a396b70723eda920672cfd36a83236818e34522 (patch)
treea57ca97b04fb1abf025caebc35d7e1ededffaba3 /net/py-magic-wormhole/Makefile
parent341ad35d27c194ba2ee160b4ae682e7fba1c8e90 (diff)
downloadports-4a396b70723eda920672cfd36a83236818e34522.tar.gz
ports-4a396b70723eda920672cfd36a83236818e34522.zip
net/py-magic-wormhole: create port
Get things from one computer to another, safely. WWW: http://magic-wormhole.io
Notes
Notes: svn path=/head/; revision=417954
Diffstat (limited to 'net/py-magic-wormhole/Makefile')
-rw-r--r--net/py-magic-wormhole/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net/py-magic-wormhole/Makefile b/net/py-magic-wormhole/Makefile
new file mode 100644
index 000000000000..94ab01d2c652
--- /dev/null
+++ b/net/py-magic-wormhole/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= magic-wormhole
+PORTVERSION= 0.8.0
+CATEGORIES= net
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Get things from one computer to another, safely
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm \
+ ${PYTHON_PKGNAMEPREFIX}hkdf>0:security/py-hkdf \
+ ${PYTHON_PKGNAMEPREFIX}autobahn>=0.14.1:www/py-autobahn \
+ ${PYTHON_PKGNAMEPREFIX}argparse>0:devel/py-argparse \
+ ${PYTHON_PKGNAMEPREFIX}pynacl>=0.3.0:security/py-pynacl \
+ ${PYTHON_PKGNAMEPREFIX}spake2>=0.7:security/py-spake2 \
+ ${PYTHON_PKGNAMEPREFIX}txaio>=2.5.1:devel/py-txaio
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>