aboutsummaryrefslogtreecommitdiff
path: root/net/py-pyroute2.ndb/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 20:44:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 20:44:05 +0000
commit7942185025f06bb6f80312b2e3a7f69b43c505a6 (patch)
tree89b8bb026a9b380db7ca72b3de20a5de88add99b /net/py-pyroute2.ndb/Makefile
parentce3df07fb392cb28ff97e2fd30af9e5835b45006 (diff)
downloadports-7942185025f06bb6f80312b2e3a7f69b43c505a6.tar.gz
ports-7942185025f06bb6f80312b2e3a7f69b43c505a6.zip
net/py-pyroute2.ndb: Add py-pyroute2.ndb 0.6.4
PyRoute2 is a pure Python netlink library. NDB is a high-level network management module. It provides a transactional DB with multiple sources, from local RTNL source to netns and remote systems. The DB provides Python API and HTTP RPC (json and plain text), my run as a standalone service or may be used as a Python module. WWW: https://github.com/svinota/pyroute2/tree/master/pyroute2.ndb
Diffstat (limited to 'net/py-pyroute2.ndb/Makefile')
-rw-r--r--net/py-pyroute2.ndb/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/py-pyroute2.ndb/Makefile b/net/py-pyroute2.ndb/Makefile
new file mode 100644
index 000000000000..4f7b9b61b55d
--- /dev/null
+++ b/net/py-pyroute2.ndb/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pyroute2.ndb
+PORTVERSION= 0.6.4
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python Netlink library: NDB module
+
+LICENSE= APACHE20 GPLv2+
+LICENSE_COMB= dual
+LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.Apache.v2
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENSE.GPL.v2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyroute2.core>=${PORTVERSION}:net/py-pyroute2.core@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>