aboutsummaryrefslogtreecommitdiff
path: root/net/py-pysendfile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-06-24 16:54:41 +0000
committerChris Rees <crees@FreeBSD.org>2012-06-24 16:54:41 +0000
commit8cb6d791e77fc7c048c3111c163fad7bd06fe9b3 (patch)
treeb1abde0573db11d6701a5cacca8f57ffded6a4f3 /net/py-pysendfile
parent0c33a9617ed303d7238c1ec62223153a167d4eae (diff)
downloadports-8cb6d791e77fc7c048c3111c163fad7bd06fe9b3.tar.gz
ports-8cb6d791e77fc7c048c3111c163fad7bd06fe9b3.zip
Replace devel/py-sendfile with net/py-pysendfile; upstream of py-sendfile
is dead and py-pysendfile is a fork. PR: ports/169177 Submitted by: koobs <koobs.freebsd@gmail.com> Approved by: maintainer of py-sendfile's email domain is parked
Notes
Notes: svn path=/head/; revision=299894
Diffstat (limited to 'net/py-pysendfile')
-rw-r--r--net/py-pysendfile/Makefile23
-rw-r--r--net/py-pysendfile/distinfo2
-rw-r--r--net/py-pysendfile/files/patch-setup.py10
-rw-r--r--net/py-pysendfile/pkg-descr6
-rw-r--r--net/py-pysendfile/pkg-plist13
5 files changed, 54 insertions, 0 deletions
diff --git a/net/py-pysendfile/Makefile b/net/py-pysendfile/Makefile
new file mode 100644
index 000000000000..70d9d2fac0da
--- /dev/null
+++ b/net/py-pysendfile/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-pysendfile
+# Date created: 2012-06-15
+# Whom: koobs <koobs.freebsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pysendfile
+PORTVERSION= 2.0.0
+CATEGORIES= net python devel
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs.freebsd@gmail.com
+COMMENT= A Python interface to sendfile(2)
+
+CONFLICTS_INSTALL= py*-sendfile-[0-9]*
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-pysendfile/distinfo b/net/py-pysendfile/distinfo
new file mode 100644
index 000000000000..9291faa611f7
--- /dev/null
+++ b/net/py-pysendfile/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pysendfile-2.0.0.tar.gz) = b7b747e47f2b1b16942d8db9139e0f0f70546ca80a06460bd5abfdc7a1bca957
+SIZE (pysendfile-2.0.0.tar.gz) = 11155
diff --git a/net/py-pysendfile/files/patch-setup.py b/net/py-pysendfile/files/patch-setup.py
new file mode 100644
index 000000000000..614e5a1d0069
--- /dev/null
+++ b/net/py-pysendfile/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- ./setup.py.orig 2012-06-17 22:22:27.000000000 +1000
++++ ./setup.py 2012-06-17 22:22:42.000000000 +1000
+@@ -79,6 +79,7 @@
+ 'Topic :: Internet :: WWW/HTTP',
+ 'License :: OSI Approved :: MIT License',
+ ],
++ zip_safe=False,
+ ext_modules = [Extension('sendfile',
+ sources=['sendfilemodule.c'],
+ libraries=libraries)],
diff --git a/net/py-pysendfile/pkg-descr b/net/py-pysendfile/pkg-descr
new file mode 100644
index 000000000000..3a123eeac275
--- /dev/null
+++ b/net/py-pysendfile/pkg-descr
@@ -0,0 +1,6 @@
+sendfile(2) is a system call which provides a "zero-copy" way of copying data
+from one file descriptor to another (a socket). The phrase "zero-copy" refers
+to the fact that all of the copying of data between the two descriptors is
+done entirely by the kernel, with no copying of data into userspace buffers.
+
+WWW: http://code.google.com/p/pysendfile
diff --git a/net/py-pysendfile/pkg-plist b/net/py-pysendfile/pkg-plist
new file mode 100644
index 000000000000..cecd8a1b4793
--- /dev/null
+++ b/net/py-pysendfile/pkg-plist
@@ -0,0 +1,13 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/sendfile.so
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/sendfile.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/sendfile.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/sendfile.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/native_libs.txt
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%