aboutsummaryrefslogtreecommitdiff
path: root/net/py-rt/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-14 09:45:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-14 09:45:04 +0000
commit5102c29909ffd7b4ec11a556d6d08866107e4544 (patch)
tree86852e1dbbdae5a52389cc83c00f5a4b1329224a /net/py-rt/Makefile
parente756b17c466f0cc78d0a785ef6650d8684e213ba (diff)
downloadports-5102c29909ffd7b4ec11a556d6d08866107e4544.tar.gz
ports-5102c29909ffd7b4ec11a556d6d08866107e4544.zip
add py-rt 2.5
Python Routeing Toolkit
Notes
Notes: svn path=/head/; revision=61257
Diffstat (limited to 'net/py-rt/Makefile')
-rw-r--r--net/py-rt/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/py-rt/Makefile b/net/py-rt/Makefile
new file mode 100644
index 000000000000..124a4260e934
--- /dev/null
+++ b/net/py-rt/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: py-rt
+# Date created: Jun 14, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rt
+PORTVERSION= 2.5
+CATEGORIES= net python
+MASTER_SITES= http://www.sprintlabs.com/Department/IP-Interworking/Routing/PyRT/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyrt-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+DOCSDIR= ${PREFIX}/share/doc/py-rt
+
+post-patch:
+.for file in bgp.py isis.py
+ @${REINPLACE_CMD} -e "s/python2/python/g" ${WRKSRC}/${file}
+.endfor
+
+do-install:
+ ${MKDIR} ${PYTHON_SITELIBDIR}/rt
+ (cd ${WRKSRC} ; ${INSTALL_SCRIPT} *.py ${PYTHON_SITELIBDIR}/rt)
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} ; ${INSTALL_SCRIPT} README* ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>