aboutsummaryrefslogtreecommitdiff
path: root/net/py-smbprotocol
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-08 17:10:45 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-08 17:10:45 +0000
commit3d2c1e8a6085a377a6894ccb5b3bf24e9e61ad05 (patch)
tree2670146517c7876cfd14670ecc3fa2df41df04d5 /net/py-smbprotocol
parent85952a237b35e7858856b615ee9ee60c8210397b (diff)
downloadports-3d2c1e8a6085a377a6894ccb5b3bf24e9e61ad05.tar.gz
ports-3d2c1e8a6085a377a6894ccb5b3bf24e9e61ad05.zip
Add py-smbprotocol 1.2.0
SMB is a network file sharing protocol and has numerous iterations over the years. This library implements the SMBv2 and SMBv3 protocol based on the MS-SMB2 document. Features: - Negotiation of the SMB 2.0.2 protocol to SMB 3.1.1 (Windows 10/Server 2016) - Authentication with both NTLM and Kerberos - Message signing - Message encryption (SMB 3.x.x+) - Connect to a Tree/Share - Opening of files, pipes and directories - Set create contexts when opening files - Read and writing of files and pipes - Sending IOCTL commands - Sending of multiple messages in one packet (compounding) - Experimental support for both standalone and DFS server shares WWW: https://github.com/jborean93/smbprotocol
Notes
Notes: svn path=/head/; revision=554479
Diffstat (limited to 'net/py-smbprotocol')
-rw-r--r--net/py-smbprotocol/Makefile25
-rw-r--r--net/py-smbprotocol/distinfo3
-rw-r--r--net/py-smbprotocol/pkg-descr18
3 files changed, 46 insertions, 0 deletions
diff --git a/net/py-smbprotocol/Makefile b/net/py-smbprotocol/Makefile
new file mode 100644
index 000000000000..e634e61b9122
--- /dev/null
+++ b/net/py-smbprotocol/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= smbprotocol
+PORTVERSION= 1.2.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Interact with a server using the SMB 2/3 Protocol
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.0:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyspnego>=0:security/py-pyspnego@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-smbprotocol/distinfo b/net/py-smbprotocol/distinfo
new file mode 100644
index 000000000000..0ba4fa46784f
--- /dev/null
+++ b/net/py-smbprotocol/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1604680058
+SHA256 (smbprotocol-1.2.0.tar.gz) = 8102adfea6750a29c7e1a99edc58931a5ff948a659f17abc1f43cfc16ea17b6a
+SIZE (smbprotocol-1.2.0.tar.gz) = 112367
diff --git a/net/py-smbprotocol/pkg-descr b/net/py-smbprotocol/pkg-descr
new file mode 100644
index 000000000000..2676db57dd99
--- /dev/null
+++ b/net/py-smbprotocol/pkg-descr
@@ -0,0 +1,18 @@
+SMB is a network file sharing protocol and has numerous iterations over the
+years. This library implements the SMBv2 and SMBv3 protocol based on the MS-SMB2
+document.
+
+Features:
+- Negotiation of the SMB 2.0.2 protocol to SMB 3.1.1 (Windows 10/Server 2016)
+- Authentication with both NTLM and Kerberos
+- Message signing
+- Message encryption (SMB 3.x.x+)
+- Connect to a Tree/Share
+- Opening of files, pipes and directories
+- Set create contexts when opening files
+- Read and writing of files and pipes
+- Sending IOCTL commands
+- Sending of multiple messages in one packet (compounding)
+- Experimental support for both standalone and DFS server shares
+
+WWW: https://github.com/jborean93/smbprotocol