aboutsummaryrefslogtreecommitdiff
path: root/net/py-tweepy
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /net/py-tweepy
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'net/py-tweepy')
-rw-r--r--net/py-tweepy/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net/py-tweepy/Makefile b/net/py-tweepy/Makefile
index 0f1e23c6b8e5..a3fbd422fd58 100644
--- a/net/py-tweepy/Makefile
+++ b/net/py-tweepy/Makefile
@@ -12,13 +12,13 @@ COMMENT= Twitter API library for Python
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.4.3:www/py-requests \
- ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0.4.1:www/py-requests-oauthlib \
- ${PYTHON_PKGNAMEPREFIX}six>=1.7.3:devel/py-six
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose \
- ${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:devel/py-mock \
- ${PYTHON_PKGNAMEPREFIX}vcrpy>=1.1.2:devel/py-vcrpy
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.4.3:www/py-requests@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0.4.1:www/py-requests-oauthlib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.7.3:devel/py-six@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:devel/py-mock@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vcrpy>=1.1.2:devel/py-vcrpy@${FLAVOR}
USES= python
USE_GITHUB= yes
@@ -31,7 +31,7 @@ TEST_ENV= USE_REPLAY=1
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3000
-TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unittest2>0:devel/py-unittest2
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unittest2>0:devel/py-unittest2@${FLAVOR}
.endif
do-test: