aboutsummaryrefslogtreecommitdiff
path: root/net/py-txamqp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-27 19:52:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-27 19:52:20 +0000
commite535ede351ed7a418188894ffc1b80fdfbc79b75 (patch)
tree4cb9f898c8dca57cf7b607d1709285f5b3b76b15 /net/py-txamqp
parent874d50422bd35ed7f24108af0b2e833f2e7e656e (diff)
downloadports-e535ede351ed7a418188894ffc1b80fdfbc79b75.tar.gz
ports-e535ede351ed7a418188894ffc1b80fdfbc79b75.zip
Update to 0.8.1
- Change MASTER_SITES from Launchpad to CHEESESHOP - Add LICENSE - Relax USES=python - Reformat pkg-descr - Update WWW Changes: https://github.com/txamqp/txamqp/commits/master
Notes
Notes: svn path=/head/; revision=457399
Diffstat (limited to 'net/py-txamqp')
-rw-r--r--net/py-txamqp/Makefile19
-rw-r--r--net/py-txamqp/distinfo5
-rw-r--r--net/py-txamqp/files/patch-src__txamqp__codec.py42
-rw-r--r--net/py-txamqp/pkg-descr10
4 files changed, 16 insertions, 60 deletions
diff --git a/net/py-txamqp/Makefile b/net/py-txamqp/Makefile
index 9b53610145e7..68a9f34b0ad3 100644
--- a/net/py-txamqp/Makefile
+++ b/net/py-txamqp/Makefile
@@ -2,26 +2,23 @@
# $FreeBSD$
PORTNAME= txamqp
-PORTVERSION= 0.3
-PORTREVISION= 4
+PORTVERSION= 0.8.1
CATEGORIES= net python
-MASTER_SITES= http://launchpadlibrarian.net/30388120/ \
- # http://launchpad.net/txamqp/trunk/${PORTVERSION}/+download/
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= python-${PORTNAME}_${PORTVERSION}.orig
+DISTNAME= txAMQP-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= Twisted Python library for the AMQP messaging protocol
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}thrift>=0:devel/py-thrift@${FLAVOR} \
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+xRUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${FLAVOR}
NO_ARCH= yes
-USES= python:2
+USES= python
USE_PYTHON= autoplist distutils
-WRKSRC= ${WRKDIR}/python-${PORTNAME}-${PORTVERSION}
-
-# TODO: Install txAMQP examples.
-
.include <bsd.port.mk>
diff --git a/net/py-txamqp/distinfo b/net/py-txamqp/distinfo
index 7bb4beb25251..fb44e518ab1a 100644
--- a/net/py-txamqp/distinfo
+++ b/net/py-txamqp/distinfo
@@ -1,2 +1,3 @@
-SHA256 (python-txamqp_0.3.orig.tar.gz) = c3900aa1e837711a06a881ae76f575af66f9e3d562bfe8ca22918477325050e4
-SIZE (python-txamqp_0.3.orig.tar.gz) = 153402
+TIMESTAMP = 1514380295
+SHA256 (txAMQP-0.8.1.tar.gz) = 3328a6f5020dc017e149bc281689b3618c13622df11b1164e041d7db1851e7d1
+SIZE (txAMQP-0.8.1.tar.gz) = 39544
diff --git a/net/py-txamqp/files/patch-src__txamqp__codec.py b/net/py-txamqp/files/patch-src__txamqp__codec.py
deleted file mode 100644
index 2281a0162437..000000000000
--- a/net/py-txamqp/files/patch-src__txamqp__codec.py
+++ /dev/null
@@ -1,42 +0,0 @@
---- src/txamqp/codec.py.orig 2009-08-16 11:25:45 UTC
-+++ src/txamqp/codec.py
-@@ -25,12 +25,12 @@ fields.
- """
-
- from cStringIO import StringIO
--from struct import *
-+from struct import pack, calcsize, unpack
-
- class EOF(Exception):
- pass
-
--class Codec:
-+class Codec(object):
-
- def __init__(self, stream):
- self.stream = stream
-@@ -153,6 +153,13 @@ class Codec:
- def decode_longstr(self):
- return self.dec_str("!L")
-
-+ # timestamp
-+ def encode_timestamp(self, o):
-+ self.pack("!Q", o)
-+
-+ def decode_timestamp(self):
-+ return self.unpack("!Q")
-+
- # table
- def encode_table(self, tbl):
- enc = StringIO()
-@@ -180,6 +187,10 @@ class Codec:
- value = self.decode_longstr()
- elif type == "I":
- value = self.decode_long()
-+ elif type == "F":
-+ value = self.decode_table()
-+ elif type == "t":
-+ value = (self.decode_octet() != 0)
- else:
- raise ValueError(repr(type))
- result[key] = value
diff --git a/net/py-txamqp/pkg-descr b/net/py-txamqp/pkg-descr
index a21fc579b4f4..5ef2f3bc4033 100644
--- a/net/py-txamqp/pkg-descr
+++ b/net/py-txamqp/pkg-descr
@@ -1,6 +1,6 @@
-This project contains all the necessary code to connect, send and
-receive messages to/from an AMQP-compliant peer or broker (Qpid,
-OpenAMQ, RabbitMQ) using Twisted. It also includes support for using
-Thrift RPC over AMQP in Twisted applications.
+This project contains all the necessary code to connect, send and receive
+messages to/from an AMQP-compliant peer or broker (Qpid, OpenAMQ, RabbitMQ)
+using Twisted. It also includes support for using Thrift RPC over AMQP in
+Twisted applications.
-WWW: https://launchpad.net/txamqp
+WWW: https://pypi.python.org/pypi/txAMQP