aboutsummaryrefslogtreecommitdiff
path: root/net/py-urllib3/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-01-14 19:26:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-01-14 19:26:18 +0000
commit8a4a40d871a2d028bb419c454be814b92f6be870 (patch)
treef5432ff230012286fa7f13cb0494e521d7fd4221 /net/py-urllib3/Makefile
parent08a5260bf007c3627c637b0112e0181da9f7d137 (diff)
downloadports-8a4a40d871a2d028bb419c454be814b92f6be870.tar.gz
ports-8a4a40d871a2d028bb419c454be814b92f6be870.zip
Urllib3 is an HTTP library with thread-safe connection pooling, and file
post. WWW: http://urllib3.readthedocs.org/ PR: ports/163972 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com>
Notes
Notes: svn path=/head/; revision=289228
Diffstat (limited to 'net/py-urllib3/Makefile')
-rw-r--r--net/py-urllib3/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net/py-urllib3/Makefile b/net/py-urllib3/Makefile
new file mode 100644
index 000000000000..80c10d59c3d7
--- /dev/null
+++ b/net/py-urllib3/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-urllib3
+# Date created: 2012-01-09
+# Whom: Olivier Duchateau <duchateau.olivier@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= urllib3
+PORTVERSION= 1.1
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= duchateau.olivier@gmail.com
+COMMENT= Enhance HTTP Python's standard library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>