aboutsummaryrefslogtreecommitdiff
path: root/net/qt5-network
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2018-12-24 20:43:00 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2018-12-24 20:43:00 +0000
commit13791ed2eac49b243f10de08355dec9e93b54820 (patch)
treefe7f47ed32e6e40e15bb871e7a38eb942859c283 /net/qt5-network
parent67ddd370a6ed4c74e6951e8b2cdac06e229aabaf (diff)
downloadports-13791ed2eac49b243f10de08355dec9e93b54820.tar.gz
ports-13791ed2eac49b243f10de08355dec9e93b54820.zip
Fix build of net/qt5-network on 12.0. Added note in the
patch about future compatibility. Reported by: jrm
Notes
Notes: svn path=/head/; revision=488281
Diffstat (limited to 'net/qt5-network')
-rw-r--r--net/qt5-network/Makefile2
-rw-r--r--net/qt5-network/files/patch-src_network_kernel_qnetworkinterface__unix.cpp19
2 files changed, 16 insertions, 5 deletions
diff --git a/net/qt5-network/Makefile b/net/qt5-network/Makefile
index ffaa7be45d62..517295725671 100644
--- a/net/qt5-network/Makefile
+++ b/net/qt5-network/Makefile
@@ -2,7 +2,7 @@
PORTNAME= network
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
PKGNAMEPREFIX= qt5-
diff --git a/net/qt5-network/files/patch-src_network_kernel_qnetworkinterface__unix.cpp b/net/qt5-network/files/patch-src_network_kernel_qnetworkinterface__unix.cpp
index 04d7b3019939..50747b2c88f0 100644
--- a/net/qt5-network/files/patch-src_network_kernel_qnetworkinterface__unix.cpp
+++ b/net/qt5-network/files/patch-src_network_kernel_qnetworkinterface__unix.cpp
@@ -7,8 +7,9 @@ Clean up interface type and MTU detection.
- In particular, don't use a union of structs passed in to ioctl().
Make them separate structs (with block scope so the compiler might
place them on top of each other, that would be ok).
+ - IFM_FDDI (still) exists in 11.2, not in 12.0
---- src/network/kernel/qnetworkinterface_unix.cpp.orig 2018-12-24 17:00:42 UTC
+--- src/network/kernel/qnetworkinterface_unix.cpp.orig 2018-12-03 11:15:26 UTC
+++ src/network/kernel/qnetworkinterface_unix.cpp
@@ -419,12 +419,23 @@ QT_BEGIN_INCLUDE_NAMESPACE
#endif // QT_PLATFORM_UIKIT
@@ -39,7 +40,17 @@ Clean up interface type and MTU detection.
static QNetworkInterface::InterfaceType probeIfType(int socket, int iftype, struct ifmediareq *req)
{
-@@ -477,15 +488,8 @@ static QNetworkInterface::InterfaceType
+@@ -463,9 +474,6 @@ static QNetworkInterface::InterfaceType
+ case IFM_ETHER:
+ return QNetworkInterface::Ethernet;
+
+- case IFM_FDDI:
+- return QNetworkInterface::Fddi;
+-
+ case IFM_IEEE80211:
+ return QNetworkInterface::Ieee80211;
+ }
+@@ -477,15 +485,8 @@ static QNetworkInterface::InterfaceType
static QList<QNetworkInterfacePrivate *> createInterfaces(ifaddrs *rawList)
{
QList<QNetworkInterfacePrivate *> interfaces;
@@ -57,7 +68,7 @@ Clean up interface type and MTU detection.
// on NetBSD we use AF_LINK and sockaddr_dl
// scan the list for that family
-@@ -500,13 +504,21 @@ static QList<QNetworkInterfacePrivate *>
+@@ -500,13 +501,21 @@ static QList<QNetworkInterfacePrivate *>
iface->flags = convertFlags(ptr->ifa_flags);
iface->hardwareAddress = iface->makeHwAddress(sdl->sdl_alen, (uchar*)LLADDR(sdl));
@@ -84,7 +95,7 @@ Clean up interface type and MTU detection.
return interfaces;
}
-@@ -605,7 +617,7 @@ static QList<QNetworkInterfacePrivate *>
+@@ -605,7 +614,7 @@ static QList<QNetworkInterfacePrivate *>
{
QList<QNetworkInterfacePrivate *> interfaces;