aboutsummaryrefslogtreecommitdiff
path: root/net/qt5-network
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2021-05-05 11:50:00 +0000
committerCharlie Li <vishwin@FreeBSD.org>2021-05-05 11:50:00 +0000
commit49012339a1f2e6bf7a64fffa6847be6e2d4d998b (patch)
treee63c7db613f1d58c9fc611de613629867f973eaf /net/qt5-network
parent7c73bf44e0e90d55b0b53f34a5a416c60a025065 (diff)
downloadports-49012339a1f2e6bf7a64fffa6847be6e2d4d998b.tar.gz
ports-49012339a1f2e6bf7a64fffa6847be6e2d4d998b.zip
net/qt5-network: fix build with LibreSSL 3.3.2
Since LibreSSL's libssl now exposes DTLS1_2_VERSION, configure detects DTLS support which changes the DTLSv1_listen(3) signature to one that LibreSSL has never supported. Force disable DTLS feature for SSL_DEFAULT=libressl or libressl-devel. Based on: https://github.com/openbsd/ports/commit/9942e8d28c4ec59d8d4a20b8bf219b10573c1f31 Reviewed by: tcberner (kde, mentor) Approved by: fluffy (kde, mentor) Differential Revision: https://reviews.freebsd.org/D29877
Diffstat (limited to 'net/qt5-network')
-rw-r--r--net/qt5-network/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net/qt5-network/Makefile b/net/qt5-network/Makefile
index 0ac1b350ad59..8b2467f1bb96 100644
--- a/net/qt5-network/Makefile
+++ b/net/qt5-network/Makefile
@@ -27,6 +27,11 @@ QT_CONFIG= openssl
BROKEN= Qt5 requires Openssl 1.1.1, upgrade to FreeBSD 12.x/13.x or add DEFAULT_VERSIONS+=ssl=[openssl|libressl*] to /etc/make.conf
.endif
+# LibreSSL does not currently support BIO_ADDR in DTLSv1_listen()
+.if ${SSL_DEFAULT:Mlibressl*}
+CONFIGURE_ARGS+= -no-feature-dtls
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${BUILD_WRKSRC}/ssl/qsslsocket_openssl.cpp