aboutsummaryrefslogtreecommitdiff
path: root/net/quagga/files
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2010-09-20 16:29:08 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2010-09-20 16:29:08 +0000
commitccf1802b33a2ee422f4f6ec0f2e79317c853f78e (patch)
tree47d0681b3f6b9b7b10eb8f83e3e737ec020ffa95 /net/quagga/files
parent5a77cd96b7bdf673e9c879000af2b650e78b9a44 (diff)
downloadports-ccf1802b33a2ee422f4f6ec0f2e79317c853f78e.tar.gz
ports-ccf1802b33a2ee422f4f6ec0f2e79317c853f78e.zip
- Revive a patch to fix ospf multicast problem
- Add a patch to fix a bug with ipv6 interfaces PR: ports/150329, ports/150455 Submitted by: Ingo Flaschberger <if at xip.at> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=261491
Diffstat (limited to 'net/quagga/files')
-rw-r--r--net/quagga/files/patch-configure.ac18
-rw-r--r--net/quagga/files/patch-lib-sockopt.c13
2 files changed, 26 insertions, 5 deletions
diff --git a/net/quagga/files/patch-configure.ac b/net/quagga/files/patch-configure.ac
index 90103c026843..aa38eac97a0b 100644
--- a/net/quagga/files/patch-configure.ac
+++ b/net/quagga/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2010-08-19 11:36:29.000000000 +0200
-+++ configure.ac 2010-08-25 09:06:04.000000000 +0200
-@@ -443,20 +443,6 @@
+--- configure.ac.orig 2010-09-13 10:10:29.000000000 +0600
++++ configure.ac 2010-09-13 10:12:36.000000000 +0600
+@@ -443,25 +443,14 @@
#endif /* TIME_WITH_SYS_TIME */
])dnl
@@ -21,7 +21,15 @@
m4_define([QUAGGA_INCLUDES],
QUAGGA_INCLUDES
[#if HAVE_NET_IF_H
-@@ -474,9 +460,6 @@
+ # include <net/if.h>
+ #endif
++#if HAVE_NETINET_IN_VAR_H
++# include <netinet/in_var.h>
++#endif
+ #if HAVE_SYS_UN_H
+ # include <sys/un.h>
+ #endif
+@@ -474,9 +463,6 @@
#if HAVE_NET_IF_DL_H
# include <net/if_dl.h>
#endif
@@ -31,7 +39,7 @@
#if HAVE_NET_NETOPT_H
# include <net/netopt.h>
#endif
-@@ -493,8 +476,23 @@
+@@ -493,8 +479,23 @@
#if HAVE_NETINET_IP_ICMP_H
# include <netinet/ip_icmp.h>
#endif
diff --git a/net/quagga/files/patch-lib-sockopt.c b/net/quagga/files/patch-lib-sockopt.c
new file mode 100644
index 000000000000..5995b3756e5f
--- /dev/null
+++ b/net/quagga/files/patch-lib-sockopt.c
@@ -0,0 +1,13 @@
+--- lib/sockopt.c.orig 2008-01-11 16:47:21.000000000 +0300
++++ lib/sockopt.c 2008-01-11 16:47:57.000000000 +0300
+@@ -23,6 +23,10 @@
+ #include "log.h"
+ #include "sockopt.h"
+
++#ifdef HAVE_STRUCT_IP_MREQN_IMR_IFINDEX
++#undef HAVE_STRUCT_IP_MREQN_IMR_IFINDEX
++#endif
++
+ int
+ setsockopt_so_recvbuf (int sock, int size)
+ {