aboutsummaryrefslogtreecommitdiff
path: root/net/queso
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-04-03 06:24:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-04-03 06:24:06 +0000
commit3a8822fad13f8931307bf92ee81d9f72a31756fd (patch)
tree7b17574e1935d705981bfeedc1cd2e64b41e724e /net/queso
parent5e1033eac3f1ec1380860fba587bfca5cbd41dd0 (diff)
downloadports-3a8822fad13f8931307bf92ee81d9f72a31756fd.tar.gz
ports-3a8822fad13f8931307bf92ee81d9f72a31756fd.zip
- Update MASTER_SITES
- Add LICENSE - Support CFLAGS properly - Support STRIP properly PR: 177554 Submitted by: ports fury Approved by: portmgr
Notes
Notes: svn path=/head/; revision=315694
Diffstat (limited to 'net/queso')
-rw-r--r--net/queso/Makefile33
1 files changed, 19 insertions, 14 deletions
diff --git a/net/queso/Makefile b/net/queso/Makefile
index b3da9c8babcb..3f8662c24a66 100644
--- a/net/queso/Makefile
+++ b/net/queso/Makefile
@@ -1,32 +1,37 @@
-# ex:ts=8
-# Ports collection makefile for: Queso
-# Date created: 13 Oct 1998
-# Whom: Wu Ching-hong <woju@freebsd.ee.ntu.edu.tw>
+# Created by: Wu Ching-hong <woju@freebsd.ee.ntu.edu.tw>
# and David O'Brien (obrien@NUXI.com)
-#
# $FreeBSD$
-#
PORTNAME= queso
PORTVERSION= 980922
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net security
-MASTER_SITES= http://ftp.cerias.purdue.edu/pub/tools/unix/scanners/queso/ \
- http://www.mirrors.wiretapped.net/security/network-mapping/
+MASTER_SITES= PACKETSTORM/UNIX/scanners
MAINTAINER= ports@FreeBSD.org
COMMENT= Determine the remote OS using simple TCP packets
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= DOCS
+
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} 's,$(CFGDIR)/queso.conf,$(CFGDIR)/queso.conf.sample,' \
- ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-O2 -pipe|| ; \
+ s|^LDFLAGS|#LDFLAGS|' ${WRKSRC}/Makefile.in
+ @${LN} -sf queso.conf ${WRKSRC}/queso.conf.sample
-post-install:
-.if !defined(NOPORTDOCS)
+do-install:
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} queso ${PREFIX}/sbin)
+ (cd ${WRKSRC} && ${INSTALL_DATA} queso.conf.sample ${PREFIX}/etc)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Documentation.txt ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} Documentation.txt ${DOCSDIR})
.endif
.include <bsd.port.mk>