aboutsummaryrefslogtreecommitdiff
path: root/net/rabbitmq/Makefile
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2019-11-14 07:27:08 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2019-11-14 07:27:08 +0000
commitf0380f797cf3961b231525835717a09aeb3246a9 (patch)
treee64fa7ad9adcc92abdcdb3634af8b253324d1d08 /net/rabbitmq/Makefile
parent8b1b71da22073de4f035ab82035aaaeb0ca112c6 (diff)
downloadports-f0380f797cf3961b231525835717a09aeb3246a9.tar.gz
ports-f0380f797cf3961b231525835717a09aeb3246a9.zip
net/rabbitmq: add new /sbin/ tools for migrations
- add upgrade helper scripts - cuttlefish is needed for handling some config settings - pet port order while here Reviewed by: olgeni Sponsored by: SkunkWerks, GmbH Differential Revision: https://reviews.freebsd.org/D22310
Notes
Notes: svn path=/head/; revision=517556
Diffstat (limited to 'net/rabbitmq/Makefile')
-rw-r--r--net/rabbitmq/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/net/rabbitmq/Makefile b/net/rabbitmq/Makefile
index 4445589d5ea6..d76e91736029 100644
--- a/net/rabbitmq/Makefile
+++ b/net/rabbitmq/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rabbitmq
DISTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://github.com/rabbitmq/rabbitmq-server/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}-server-${PORTVERSION}
@@ -21,6 +22,11 @@ BUILD_DEPENDS= erlang-runtime21>=21.3:lang/erlang-runtime21 \
rsync:net/rsync
RUN_DEPENDS= erlang-runtime21>=21.3:lang/erlang-runtime21
+USES= cpe gmake shebangfix tar:xz
+USE_LOCALE= en_US.UTF-8
+USE_RC_SUBR= rabbitmq
+NO_ARCH= yes
+
OPTIONS_DEFINE= ADMIN
OPTIONS_SUB= yes
@@ -29,10 +35,6 @@ ADMIN_USES= python
ADMIN_USES_OFF= python:build
ALL_TARGET= install
-USES= cpe gmake shebangfix tar:xz
-USE_LOCALE= en_US.UTF-8
-USE_RC_SUBR= rabbitmq
-NO_ARCH= yes
USERS= rabbitmq
GROUPS= rabbitmq
@@ -73,7 +75,7 @@ post-install:
${STAGEDIR}${PREFIX}/etc/rabbitmq/advanced.config.sample
${INSTALL_DATA} ${WRKSRC}/deps/rabbit/docs/rabbitmq.conf.example \
${STAGEDIR}${PREFIX}/etc/rabbitmq/rabbitmq.conf.sample
-.for _file in rabbitmq-defaults rabbitmq-diagnostics rabbitmq-env rabbitmq-plugins rabbitmq-server rabbitmqctl
+.for _file in cuttlefish rabbitmq-defaults rabbitmq-diagnostics rabbitmq-env rabbitmq-plugins rabbitmq-server rabbitmq-upgrade rabbitmqctl
${LN} -s ../lib/rabbitmq_server-${PORTVERSION}/sbin/${_file} ${STAGEDIR}${PREFIX}/sbin
.endfor
${INSTALL_MAN} ${WRKSRC}/deps/rabbit/docs/*.8 ${STAGEDIR}${MAN1PREFIX}/man/man8