aboutsummaryrefslogtreecommitdiff
path: root/net/rinetd/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-08-07 19:19:02 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-08-07 19:19:02 +0000
commit9dbe2a10e8e49e68704a8b1efcc38f1de9632a9c (patch)
tree88b2ee6ebcd676f050322dcbc4df29ab203c49bb /net/rinetd/Makefile
parent7bc4c72e78d2b32a90843c2740be23343bf64042 (diff)
downloadports-9dbe2a10e8e49e68704a8b1efcc38f1de9632a9c.tar.gz
ports-9dbe2a10e8e49e68704a8b1efcc38f1de9632a9c.zip
Fix problem introduced in r302141. The directory for the unpacked source
files is unversioned, so it conflicts with the name of the rc.d script in WRKDIR after SUB_FILES is applied. This is the same method as suggested in the PR (and that I've used previously), just slightly different in the details. PR: ports/170441 Submitted by: Frank Wall <fw@moov.de> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=302255
Diffstat (limited to 'net/rinetd/Makefile')
-rw-r--r--net/rinetd/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/rinetd/Makefile b/net/rinetd/Makefile
index 493ca5176761..75e82e91a5c8 100644
--- a/net/rinetd/Makefile
+++ b/net/rinetd/Makefile
@@ -19,7 +19,7 @@ COMMENT= A simple TCP port redirector
OPTIONS_DEFINE= DOCS
-WRKSRC= ${WRKDIR}/rinetd/
+WRKSRC= ${WRKDIR}/rinetd-${PORTVERSION}
MAKE_JOBS_SAFE= yes
USE_DOS2UNIX= yes
@@ -32,6 +32,9 @@ USE_RC_SUBR= rinetd
.include <bsd.port.pre.mk>
+post-extract:
+ @${MV} ${WRKDIR}/rinetd ${WRKSRC}
+
post-patch:
@${REINPLACE_CMD} -E "s,(/etc/rinetd.conf),${PREFIX}\1," \
${WRKSRC}/rinetd.[8c]