aboutsummaryrefslogtreecommitdiff
path: root/net/rp-pppoe
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2010-06-13 12:27:22 +0000
committerMatthias Andree <mandree@FreeBSD.org>2010-06-13 12:27:22 +0000
commit2c1456d955451cb14d142a0b22818ef64cd5868e (patch)
treedbd0ce071c6026fda45e1ac1292f26e708a9bea0 /net/rp-pppoe
parent94268fd0825b66ed84077dabbf3ae1cbb9314eea (diff)
downloadports-2c1456d955451cb14d142a0b22818ef64cd5868e.tar.gz
ports-2c1456d955451cb14d142a0b22818ef64cd5868e.zip
Upgrade to new upstream version 3.10
Approved by: garga (mentor, implicit)
Notes
Notes: svn path=/head/; revision=256476
Diffstat (limited to 'net/rp-pppoe')
-rw-r--r--net/rp-pppoe/Makefile26
-rw-r--r--net/rp-pppoe/distinfo6
-rw-r--r--net/rp-pppoe/files/patch-if.c11
-rw-r--r--net/rp-pppoe/files/patch-libevent__event.c23
-rw-r--r--net/rp-pppoe/files/patch-pppoe.c18
-rw-r--r--net/rp-pppoe/pkg-descr2
6 files changed, 18 insertions, 68 deletions
diff --git a/net/rp-pppoe/Makefile b/net/rp-pppoe/Makefile
index 043480a2cb9d..116f2767635e 100644
--- a/net/rp-pppoe/Makefile
+++ b/net/rp-pppoe/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rp-pppoe
-PORTVERSION= 3.8
+PORTVERSION= 3.10
CATEGORIES= net
MASTER_SITES= http://www.roaringpenguin.com/files/download/
@@ -18,6 +18,8 @@ PATCH_WRKSRC= ${WRKSRC}/src
CONFIGURE_WRKSRC= ${WRKSRC}/src
BUILD_WRKSRC= ${WRKSRC}/src
+MAKE_JOBS_SAFE= yes
+
MAN5= pppoe.conf.5
MAN8= pppoe-connect.8 pppoe-setup.8 pppoe-start.8 pppoe-status.8 \
pppoe-stop.8 pppoe-relay.8 pppoe-server.8 pppoe.8
@@ -51,36 +53,36 @@ post-patch:
do-install:
# Binaries
.for f in pppoe pppoe-server pppoe-relay
- @${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${PREFIX}/sbin
.endfor
# Configurations
- @${MKDIR} ${PREFIX}/etc/ppp
+ ${MKDIR} ${PREFIX}/etc/ppp
.for f in ${CONFIG_FILES}
- @${INSTALL_DATA} ${WRKSRC}/configs/${f} \
+ ${INSTALL_DATA} ${WRKSRC}/configs/${f} \
${PREFIX}/etc/ppp/${f}.sample
.endfor
# Manual pages
- @${MKDIR} ${MAN5PREFIX}/man/man5
+ ${MKDIR} ${MAN5PREFIX}/man/man5
.for f in ${MAN5}
- @${INSTALL_MAN} ${WRKSRC}/man/${f} ${MAN5PREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/man/${f} ${MAN5PREFIX}/man/man5
.endfor
- @${MKDIR} ${MAN8PREFIX}/man/man8
+ ${MKDIR} ${MAN8PREFIX}/man/man8
.for f in ${MAN8}
- @${INSTALL_MAN} ${WRKSRC}/man/${f} ${MAN8PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/man/${f} ${MAN8PREFIX}/man/man8
.endfor
# Scripts
.for f in ${SCRIPT_FILES}
- @${INSTALL_SCRIPT} ${WRKSRC}/scripts/${f} ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/${f} ${PREFIX}/sbin
.endfor
# Startup scripts
.for f in 04pppoe-relay.sh.sample 04pppoe-server.sh.sample
- @${INSTALL_SCRIPT} ${FILESDIR}/${f} ${PREFIX}/etc/rc.d/
+ ${INSTALL_SCRIPT} ${FILESDIR}/${f} ${PREFIX}/etc/rc.d/
.endfor
# Documentation
.ifndef (NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif # NOPORTDOCS
.include <bsd.port.mk>
diff --git a/net/rp-pppoe/distinfo b/net/rp-pppoe/distinfo
index 9016c5d8f686..a1c7dea8f688 100644
--- a/net/rp-pppoe/distinfo
+++ b/net/rp-pppoe/distinfo
@@ -1,3 +1,3 @@
-MD5 (rp-pppoe-3.8.tar.gz) = 0e32760f498f9cde44081ee6aafc823b
-SHA256 (rp-pppoe-3.8.tar.gz) = d916e9cfe1e62395f63a5361936fa855f6d0f0a37dc7227b394cdb725f553479
-SIZE (rp-pppoe-3.8.tar.gz) = 212931
+MD5 (rp-pppoe-3.10.tar.gz) = d58a13cc4185bca6121a606ff456dec0
+SHA256 (rp-pppoe-3.10.tar.gz) = 709ca7402594acc1d80b99c20219112b5c00e6ac48ae6049fc626fbaf4ce49f6
+SIZE (rp-pppoe-3.10.tar.gz) = 215288
diff --git a/net/rp-pppoe/files/patch-if.c b/net/rp-pppoe/files/patch-if.c
deleted file mode 100644
index 7826214afa3b..000000000000
--- a/net/rp-pppoe/files/patch-if.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- if.c.orig Thu Apr 6 01:14:48 2006
-+++ if.c Thu Apr 6 01:14:58 2006
-@@ -99,7 +99,7 @@
-
- static unsigned char *bpfBuffer; /* Packet filter buffer */
- static int bpfLength = 0; /* Packet filter buffer length */
--static int bpfSize = 0; /* Number of unread bytes in buffer */
-+ int bpfSize = 0; /* Number of unread bytes in buffer */
- static int bpfOffset = 0; /* Current offset in bpfBuffer */
- #endif
-
diff --git a/net/rp-pppoe/files/patch-libevent__event.c b/net/rp-pppoe/files/patch-libevent__event.c
deleted file mode 100644
index 5ca3b58e96e1..000000000000
--- a/net/rp-pppoe/files/patch-libevent__event.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- libevent/event.c.orig Sat Apr 8 16:15:20 2006
-+++ libevent/event.c Sat Apr 8 16:15:50 2006
-@@ -86,9 +86,6 @@
-
- struct timeval abs_timeout, now;
-
-- /* Avoid compiler warning */
-- abs_timeout.tv_sec = 0;
-- abs_timeout.tv_usec = 0;
- struct timeval timeout;
- struct timeval *tm;
- EventHandler *eh;
-@@ -100,6 +97,10 @@
- int foundWriteEvent = 0;
- int maxfd = -1;
- int pastDue;
-+
-+ /* Avoid compiler warning */
-+ abs_timeout.tv_sec = 0;
-+ abs_timeout.tv_usec = 0;
-
- EVENT_DEBUG(("Enter Event_HandleEvent(es=%p)\n", (void *) es));
-
diff --git a/net/rp-pppoe/files/patch-pppoe.c b/net/rp-pppoe/files/patch-pppoe.c
deleted file mode 100644
index c550e8a68129..000000000000
--- a/net/rp-pppoe/files/patch-pppoe.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- pppoe.c.orig Sat Apr 8 16:11:14 2006
-+++ pppoe.c Sat Apr 8 16:11:53 2006
-@@ -409,6 +409,7 @@
- unsigned int s; /* Temporary to hold session */
- FILE *pidfile;
- unsigned int discoveryType, sessionType;
-+ char const *options;
-
- PPPoEConnection conn;
-
-@@ -434,7 +435,6 @@
- /* Initialize syslog */
- openlog("pppoe", LOG_PID, LOG_DAEMON);
-
-- char const *options;
- #ifdef DEBUGGING_ENABLED
- options = "I:VAT:D:hS:C:Usm:np:e:kdf:F:t:";
- #else
diff --git a/net/rp-pppoe/pkg-descr b/net/rp-pppoe/pkg-descr
index 3f5ae3eb4436..9a6115bd2230 100644
--- a/net/rp-pppoe/pkg-descr
+++ b/net/rp-pppoe/pkg-descr
@@ -7,4 +7,4 @@ Note that this port has had little testing (it works on 5-CURRENT
to access T-Online in Germany from the client side) and the server side
is entirely untested.
-WWW: http://www.roaringpenguin.com/penguin/openSourceProducts/rpPppoe
+WWW: http://www.roaringpenguin.com/products/pppoe