aboutsummaryrefslogtreecommitdiff
path: root/net/rp-pppoe
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-05-27 22:33:47 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-05-27 22:33:47 +0000
commite26d30ae8b50086629896d3a7a2b39c276a07a37 (patch)
treee866ca7a9107ae04a8710d785abb2c9b2fbd440a /net/rp-pppoe
parent271f1843e0b4fb9fc31b9874db8995422c65b69a (diff)
downloadports-e26d30ae8b50086629896d3a7a2b39c276a07a37.tar.gz
ports-e26d30ae8b50086629896d3a7a2b39c276a07a37.zip
Update to new upstream release 3.14.
Notes
Notes: svn path=/head/; revision=536727
Diffstat (limited to 'net/rp-pppoe')
-rw-r--r--net/rp-pppoe/Makefile4
-rw-r--r--net/rp-pppoe/distinfo6
-rw-r--r--net/rp-pppoe/files/patch-configure4
-rw-r--r--net/rp-pppoe/files/patch-if.c8
-rw-r--r--net/rp-pppoe/files/patch-pppoe.h4
-rw-r--r--net/rp-pppoe/files/patch-relay.c18
-rw-r--r--net/rp-pppoe/files/patch-relay.h4
7 files changed, 24 insertions, 24 deletions
diff --git a/net/rp-pppoe/Makefile b/net/rp-pppoe/Makefile
index ae5610a177a8..a2ae7ee66f0c 100644
--- a/net/rp-pppoe/Makefile
+++ b/net/rp-pppoe/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= rp-pppoe
-PORTVERSION= 3.13
-PORTREVISION= 1
+PORTVERSION= 3.14
+PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= https://dianne.skoll.ca/projects/rp-pppoe/download/
diff --git a/net/rp-pppoe/distinfo b/net/rp-pppoe/distinfo
index 27c7feae36f7..1cc7668d7036 100644
--- a/net/rp-pppoe/distinfo
+++ b/net/rp-pppoe/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1545915011
-SHA256 (rp-pppoe-3.13.tar.gz) = 8cd6bc71ba46bd5f6eb4daf60220ccdcd991a8525111dee466501b1b9717e676
-SIZE (rp-pppoe-3.13.tar.gz) = 224204
+TIMESTAMP = 1590618245
+SHA256 (rp-pppoe-3.14.tar.gz) = 7825232f64ab4d618ef074d62d145ae43d6edc91b9a718c6130a4742bac40e2a
+SIZE (rp-pppoe-3.14.tar.gz) = 224688
diff --git a/net/rp-pppoe/files/patch-configure b/net/rp-pppoe/files/patch-configure
index da60b994cfcb..296f0a5c5d31 100644
--- a/net/rp-pppoe/files/patch-configure
+++ b/net/rp-pppoe/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-11-25 22:25:28 UTC
+--- configure.orig 2020-05-27 00:29:37 UTC
+++ configure
-@@ -4715,7 +4715,7 @@ eval "WRAPPER=${WRAPPER}"
+@@ -4620,7 +4620,7 @@ eval "WRAPPER=${WRAPPER}"
# Determine what targets to build
diff --git a/net/rp-pppoe/files/patch-if.c b/net/rp-pppoe/files/patch-if.c
index 1617f31722ba..cf9dc48817f5 100644
--- a/net/rp-pppoe/files/patch-if.c
+++ b/net/rp-pppoe/files/patch-if.c
@@ -1,6 +1,6 @@
---- if.c.orig 2018-11-25 22:25:28 UTC
+--- if.c.orig 2020-05-27 00:29:37 UTC
+++ if.c
-@@ -276,7 +276,7 @@ initFilter(int fd, UINT16_t type, unsigned char *hwadd
+@@ -277,7 +277,7 @@ initFilter(int fd, UINT16_t type, unsigned char *hwadd
* traffic on this network.
***********************************************************************/
int
@@ -9,7 +9,7 @@
{
static int fd = -1;
char bpfName[32];
-@@ -287,7 +287,12 @@ openInterface(char const *ifname, UINT16_t type, unsig
+@@ -288,7 +288,12 @@ openInterface(char const *ifname, UINT16_t type, unsig
int i;
/* BSD only opens one socket for both Discovery and Session packets */
@@ -22,7 +22,7 @@
return fd;
}
-@@ -396,6 +401,8 @@ openInterface(char const *ifname, UINT16_t type, unsig
+@@ -397,6 +402,8 @@ openInterface(char const *ifname, UINT16_t type, unsig
ifname);
rp_fatal(buffer);
}
diff --git a/net/rp-pppoe/files/patch-pppoe.h b/net/rp-pppoe/files/patch-pppoe.h
index 3f3064114a4b..7fc144786d2e 100644
--- a/net/rp-pppoe/files/patch-pppoe.h
+++ b/net/rp-pppoe/files/patch-pppoe.h
@@ -1,6 +1,6 @@
---- pppoe.h.orig 2018-11-25 22:25:28 UTC
+--- pppoe.h.orig 2020-05-27 00:29:37 UTC
+++ pppoe.h
-@@ -65,10 +65,14 @@ extern int IsSetID;
+@@ -62,10 +62,14 @@ extern int IsSetID;
#include <net/if_ppp.h>
#endif
diff --git a/net/rp-pppoe/files/patch-relay.c b/net/rp-pppoe/files/patch-relay.c
index 80e2a218b449..e94c2533b57c 100644
--- a/net/rp-pppoe/files/patch-relay.c
+++ b/net/rp-pppoe/files/patch-relay.c
@@ -1,6 +1,6 @@
---- relay.c.orig 2018-11-25 22:25:28 UTC
+--- relay.c.orig 2020-05-27 00:29:37 UTC
+++ relay.c
-@@ -754,6 +754,11 @@ void
+@@ -756,6 +756,11 @@ void
relayLoop()
{
fd_set readable, readableCopy;
@@ -12,7 +12,7 @@
int maxFD;
int i, r;
int sock;
-@@ -783,6 +788,27 @@ relayLoop()
+@@ -785,6 +790,27 @@ relayLoop()
continue;
}
@@ -26,7 +26,7 @@
+ continue;
+
+ /* Ignore unknown code/version */
-+ if (packet.ver != 1 || packet.type != 1)
++ if (PPPOE_VER(packet.vertype) != 1 || PPPOE_TYPE(packet.vertype) != 1)
+ continue;
+
+ type = etherType(&packet);
@@ -40,7 +40,7 @@
/* Handle session packets first */
for (i=0; i<NumInterfaces; i++) {
if (FD_ISSET(Interfaces[i].sessionSock, &readableCopy)) {
-@@ -797,6 +823,7 @@ relayLoop()
+@@ -799,6 +825,7 @@ relayLoop()
}
}
@@ -48,7 +48,7 @@
/* Handle the session-cleaning process */
if (FD_ISSET(CleanPipe[0], &readableCopy)) {
char dummy;
-@@ -816,7 +843,47 @@ relayLoop()
+@@ -818,7 +845,47 @@ relayLoop()
*%DESCRIPTION:
* Receives and processes a discovery packet.
***********************************************************************/
@@ -96,7 +96,7 @@
relayGotDiscoveryPacket(PPPoEInterface const *iface)
{
PPPoEPacket packet;
-@@ -863,6 +930,7 @@ relayGotDiscoveryPacket(PPPoEInterface const *iface)
+@@ -865,6 +932,7 @@ relayGotDiscoveryPacket(PPPoEInterface const *iface)
iface->name, (int) packet.code);
}
}
@@ -104,7 +104,7 @@
/**********************************************************************
*%FUNCTION: relayGotSessionPacket
-@@ -873,7 +941,66 @@ relayGotDiscoveryPacket(PPPoEInterface const *iface)
+@@ -875,7 +943,66 @@ relayGotDiscoveryPacket(PPPoEInterface const *iface)
*%DESCRIPTION:
* Receives and processes a session packet.
***********************************************************************/
@@ -171,7 +171,7 @@
relayGotSessionPacket(PPPoEInterface const *iface)
{
PPPoEPacket packet;
-@@ -939,6 +1066,7 @@ relayGotSessionPacket(PPPoEInterface const *iface)
+@@ -941,6 +1068,7 @@ relayGotSessionPacket(PPPoEInterface const *iface)
#endif
sendPacket(NULL, sh->interface->sessionSock, &packet, size);
}
diff --git a/net/rp-pppoe/files/patch-relay.h b/net/rp-pppoe/files/patch-relay.h
index 069005ff3698..a5ba7a92f646 100644
--- a/net/rp-pppoe/files/patch-relay.h
+++ b/net/rp-pppoe/files/patch-relay.h
@@ -1,6 +1,6 @@
---- relay.h.orig 2018-11-25 22:25:28 UTC
+--- relay.h.orig 2020-05-27 00:29:37 UTC
+++ relay.h
-@@ -51,8 +51,13 @@ typedef struct SessionHashStruct {
+@@ -52,8 +52,13 @@ typedef struct SessionHashStruct {
/* Function prototypes */