aboutsummaryrefslogtreecommitdiff
path: root/net/rsync
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2008-06-26 14:03:48 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2008-06-26 14:03:48 +0000
commit4a47fea9cec4312bed23e0231e6ec8fef24231f6 (patch)
tree12d613a6f5c48c89523adeba8b64ee8c418d91db /net/rsync
parent1bfd5ca751a4910dd1356669ee03fb91a208d897 (diff)
downloadports-4a47fea9cec4312bed23e0231e6ec8fef24231f6.tar.gz
ports-4a47fea9cec4312bed23e0231e6ec8fef24231f6.zip
Provide an optional "Time limit patch"
PR: 124553 Submitted by: Adrian Thearle <adrian@thearle.com.au>
Notes
Notes: svn path=/head/; revision=215799
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 917afe73d14d..d120cff67cd5 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -42,11 +42,20 @@ OPTIONS= POPT_PORT "Use popt from devel/popt instead of bundled one" off \
SSH "Use SSH instead of RSH" on \
FLAGS "File system flags support patch, adds --fileflags" off \
ACL "Add backward-compatibility for the --acls option" off \
- ICONV "Add iconv support" off
+ ICONV "Add iconv support" off \
+ TIMELIMIT "Time limit patch" off
.include <bsd.port.pre.mk>
-.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum)
+.if !defined(WITHOUT_TIMELIMIT)
+PATCH_STRIP= -p1
+EXTRA_PATCHES+= ${WRKSRC}/patches/time-limit.diff
+.if defined(WITH_FLAGS)
+IGNORE= flags and timelimit can't be both enabled at the same time. Please rerun 'make config' and disable one of them
+.endif
+.endif
+
+.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum) || defined(WITH_TIMELIMIT)
DISTFILES+= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
.endif