aboutsummaryrefslogtreecommitdiff
path: root/net/rsync
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2012-04-03 21:08:40 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2012-04-03 21:08:40 +0000
commitc32ba7b6af47ae3725e21ce6e3bde7e090a3bf0d (patch)
tree7949683c89f8199538911dac1f1da1bda53e733a /net/rsync
parent078c4a44780304e3b092cbf0571ab499da8228f8 (diff)
downloadports-c32ba7b6af47ae3725e21ce6e3bde7e090a3bf0d.tar.gz
ports-c32ba7b6af47ae3725e21ce6e3bde7e090a3bf0d.zip
Introduce an option that builds rsync with the "detect-renamed" patch. It
detects renamed hierarchies and avoids re-copying the files in those hierarchies. Requested by: "J.R. Oldroyd" <jr@opal.com> (via mail) Feature safe: yes
Notes
Notes: svn path=/head/; revision=294170
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 5ab2ba7487df..c14c9ef0a297 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -43,7 +43,8 @@ OPTIONS= POPT_PORT "Use popt from devel/popt instead of bundled one" off \
ATIMES "Preserve access times, adds --atimes" off \
ACL "Add backward-compatibility for the --acls option" off \
ICONV "Add iconv support" off \
- TIMELIMIT "Time limit patch" off
+ TIMELIMIT "Time limit patch" off \
+ RENAMED "Add support for renamed file detection" on
.include <bsd.port.pre.mk>
@@ -66,7 +67,7 @@ IGNORE= flags and atimes can't be enabled simultaneously. Please rerun 'make co
.endif
.endif
-.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum) || defined(WITH_TIMELIMIT) || defined(WITH_ATIMES)
+.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum) || defined(WITH_TIMELIMIT) || defined(WITH_ATIMES) || defined(WITH_RENAMED)
DISTFILES+= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
CFLAGS+= -I${LOCALBASE}/include
.endif
@@ -87,6 +88,11 @@ PATCH_STRIP= -p1
EXTRA_PATCHES+= ${WRKSRC}/patches/fileflags.diff
.endif
+.if defined(WITH_RENAMED)
+PATCH_STRIP= -p1
+EXTRA_PATCHES+= ${WRKSRC}/patches/detect-renamed.diff
+.endif
+
.if defined(WITH_ACL)
PATCH_STRIP= -p1
EXTRA_PATCHES+= ${WRKSRC}/patches/acls.diff