aboutsummaryrefslogtreecommitdiff
path: root/net/rsync
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2020-07-28 23:51:00 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2020-07-28 23:51:00 +0000
commitf180a39684b6850a79fdb7ee2c96a11c9511834b (patch)
tree69a07c4a4ace742e24e1f2320349391cf5a618ad /net/rsync
parenta118852d2c337637600f98ceba9a699c9be25dfe (diff)
downloadports-f180a39684b6850a79fdb7ee2c96a11c9511834b.tar.gz
ports-f180a39684b6850a79fdb7ee2c96a11c9511834b.zip
rsync: Unbreak and fix depends
rsync now depends on stuff in LOCALBASE. Previously, clang only needed to know about LOCALBASE if POPT or ICONV was enabled. When those options are off, xxhash and zstd were not found by configure. Also, a depend on libssl was missing, and there were some noop reinplaces. With hat: portmgr
Notes
Notes: svn path=/head/; revision=543637
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 414789f4230b..d93ebffedfc5 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -19,7 +19,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libxxhash.so:devel/xxhash \
libzstd.so:archivers/zstd
-USES= cpe shebangfix
+USES= cpe shebangfix ssl
SHEBANG_FILES= support/rrsync
CPE_VENDOR= samba
@@ -35,6 +35,8 @@ TEST_TARGET= check
CONFIGURE_ARGS= --disable-debug --enable-ipv6 \
--with-rsyncd-conf=${ETCDIR}/rsyncd.conf
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= NEWS.md README.md csprotocol.txt tech_report.tex
@@ -69,13 +71,9 @@ ACL_EXTRA_PATCHES= ${WRKSRC}/patches/acls.diff \
${FILESDIR}/extrapatch-acl
ICONV_USES= iconv:translit
-ICONV_CPPFLAGS= -I${LOCALBASE}/include
-ICONV_LDFLAGS= -L${LOCALBASE}/lib
ICONV_CONFIGURE_ENABLE= iconv iconv-open
POPT_PORT_LIB_DEPENDS= libpopt.so:devel/popt
-POPT_PORT_CPPFLAGS= -I${LOCALBASE}/include
-POPT_PORT_LDFLAGS= -L${LOCALBASE}/lib
POPT_PORT_CONFIGURE_OFF= --with-included-popt
@@ -100,9 +98,8 @@ CONFIGURE_ARGS+=ac_cv_search_libiconv_open=no
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|perl.*|${DO_NADA}|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's:/etc/:${ETCDIR}/:g' \
- ${WRKSRC}/rsync.h ${WRKSRC}/rsync.1 ${WRKSRC}/rsyncd.conf.5
+ ${WRKSRC}/rsync.1 ${WRKSRC}/rsyncd.conf.5
@${REINPLACE_CMD} -e 's|/usr/bin/rsync|${PREFIX}/bin/rsync|g' ${WRKSRC}/support/rrsync
post-install: