aboutsummaryrefslogtreecommitdiff
path: root/net/rtg
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2014-05-30 08:05:11 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2014-05-30 08:05:11 +0000
commitced114a7f4fb65f4faa5a475931345e3d37dcd6e (patch)
tree032a1338eef3100ec638d236c01dfd7963f7983d /net/rtg
parentd225bee350a699ef6ef6b4058707678fe864bddf (diff)
downloadports-ced114a7f4fb65f4faa5a475931345e3d37dcd6e.tar.gz
ports-ced114a7f4fb65f4faa5a475931345e3d37dcd6e.zip
- Convert to STAGE
PR: ports/189620 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=355800
Diffstat (limited to 'net/rtg')
-rw-r--r--net/rtg/Makefile14
-rw-r--r--net/rtg/files/patch-etc-Makefile.in22
-rw-r--r--net/rtg/files/pkg-message.in2
-rw-r--r--net/rtg/pkg-plist20
4 files changed, 33 insertions, 25 deletions
diff --git a/net/rtg/Makefile b/net/rtg/Makefile
index 0eaf3c904481..fe5b818e332e 100644
--- a/net/rtg/Makefile
+++ b/net/rtg/Makefile
@@ -3,25 +3,28 @@
PORTNAME= rtg
PORTVERSION= 0.7.4
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= net
MASTER_SITES= SF
MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= A flexible, high-performance SNMP statistics monitoring system
-LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp
+LICENSE= GPLv2
-MAN1= rtgplot.1 rtgpoll.1
+LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
USE_RC_SUBR= rtgpoll
USE_MYSQL= yes
+WANT_PERL= yes
+USES= shebangfix
+SHEBANG_FILES= etc/95.pl etc/report.pl
+SUB_FILES= pkg-message
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/${PORTNAME} \
--with-mysql=${LOCALBASE} \
--with-snmp=${LOCALBASE}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ( ${OSVERSION} >= 800040 )
@@ -36,7 +39,4 @@ post-patch:
@${MV} ${WRKSRC}/etc/rtg.conf ${WRKSRC}/etc/rtg.conf.sample
@${MV} ${WRKSRC}/etc/routers ${WRKSRC}/etc/routers.sample
-post-install:
- @${ECHO} "To enable the web interface, copy ${PREFIX}/bin/rtgplot to your site cgi-bin as rtgplot.cgi"
-
.include <bsd.port.post.mk>
diff --git a/net/rtg/files/patch-etc-Makefile.in b/net/rtg/files/patch-etc-Makefile.in
index 970d31eac6f5..bd501098bad9 100644
--- a/net/rtg/files/patch-etc-Makefile.in
+++ b/net/rtg/files/patch-etc-Makefile.in
@@ -1,14 +1,15 @@
--- etc/Makefile.in.orig 2003-10-02 16:59:32.000000000 +0100
-+++ etc/Makefile.in 2010-07-04 03:34:26.379748720 +0100
++++ etc/Makefile.in 2014-05-10 17:29:11.995407415 +0100
@@ -84,19 +84,19 @@
install_sh = @install_sh@
top_builddir = ..
-etcdir = /etc
-webdir = /web
+-reportsdir = /bin
+etcdir = @etcdir@
+webdir = @webdir@
- reportsdir = /bin
++reportsdir = @bindir@
-ETC = rtg.conf rtgtargmkr.pl routers createdb BER.pm \
+ETC = rtg.conf.sample rtgtargmkr.pl routers.sample createdb BER.pm \
@@ -25,21 +26,24 @@
subdir = etc
mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
-@@ -220,13 +220,13 @@
+@@ -220,14 +220,14 @@
all:
install: installdirs
- @for i in $(ETC) ; do $(INSTALL) $(srcdir)/$$i $(prefix)$(etcdir) ; echo "install: installed $$i in $(prefix)$(etcdir)" ; done
- @for i in $(WEB) ; do $(INSTALL) $(srcdir)/$$i $(prefix)$(webdir) ; echo "install: installed $$i in $(prefix)$(webdir)" ; done
-+ @for i in $(ETC) ; do $(INSTALL) $(srcdir)/$$i $(etcdir) ; echo "install: installed $$i in $(etcdir)" ; done
-+ @for i in $(WEB) ; do $(INSTALL) $(srcdir)/$$i $(webdir) ; echo "install: installed $$i in $(webdir)" ; done
- @for i in $(REPORTS) ; do $(INSTALL) $(srcdir)/$$i $(prefix)$(reportsdir) ; echo "install: installed $$i in $(prefix)$(reportsdir)" ; done
+- @for i in $(REPORTS) ; do $(INSTALL) $(srcdir)/$$i $(prefix)$(reportsdir) ; echo "install: installed $$i in $(prefix)$(reportsdir)" ; done
++ @for i in $(ETC) ; do $(INSTALL) $(srcdir)/$$i $(DESTDIR)$(etcdir) ; echo "install: installed $$i in $(DESTDIR)$(etcdir)" ; done
++ @for i in $(WEB) ; do $(INSTALL) $(srcdir)/$$i $(DESTDIR)$(webdir) ; echo "install: installed $$i in $(DESTDIR)$(webdir)" ; done
++ @for i in $(REPORTS) ; do $(INSTALL) $(srcdir)/$$i $(DESTDIR)$(reportsdir) ; echo "install: installed $$i in $(DESTDIR)$(reportsdir)" ; done
installdirs:
- $(mkinstalldirs) $(prefix)$(etcdir)
- $(mkinstalldirs) $(prefix)$(webdir)
-+ $(mkinstalldirs) $(etcdir)
-+ $(mkinstalldirs) $(webdir)
- $(mkinstalldirs) $(prefix)$(reportsdir)
+- $(mkinstalldirs) $(prefix)$(reportsdir)
++ $(mkinstalldirs) $(DESTDIR)$(etcdir)
++ $(mkinstalldirs) $(DESTDIR)$(webdir)
++ $(mkinstalldirs) $(DESTDIR)$(reportsdir)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/net/rtg/files/pkg-message.in b/net/rtg/files/pkg-message.in
new file mode 100644
index 000000000000..39b0db035144
--- /dev/null
+++ b/net/rtg/files/pkg-message.in
@@ -0,0 +1,2 @@
+To enable the web interface, copy %%PREFIX%%/bin/rtgplot to your site cgi-bin as rtgplot.cgi
+Without this step, your graphs will be broken.
diff --git a/net/rtg/pkg-plist b/net/rtg/pkg-plist
index 942998b26b6f..b5e9595bb32b 100644
--- a/net/rtg/pkg-plist
+++ b/net/rtg/pkg-plist
@@ -4,22 +4,24 @@ bin/rtgplot
bin/rtgpoll
contrib/README
contrib/rtgtargmkr-with-modules-0.2.tar.gz
-etc/rtg/rtg.conf.sample
-etc/rtg/rtgtargmkr.pl
-etc/rtg/routers.sample
-etc/rtg/createdb
-etc/rtg/BER.pm
-etc/rtg/SNMP_Session.pm
-etc/rtg/SNMP_util.pm
+%%ETCDIR%%/rtg.conf.sample
+%%ETCDIR%%/rtgtargmkr.pl
+%%ETCDIR%%/routers.sample
+%%ETCDIR%%/createdb
+%%ETCDIR%%/BER.pm
+%%ETCDIR%%/SNMP_Session.pm
+%%ETCDIR%%/SNMP_util.pm
include/common.h
include/rtg.h
include/rtgplot.h
+man/man1/rtgplot.1.gz
+man/man1/rtgpoll.1.gz
www/data/95.php
www/data/common.php
www/data/rtg.php
www/data/rtg.png
www/data/rtgback.png
www/data/view.php
-@dirrm contrib
-@dirrm etc/rtg
+@dirrmtry contrib
+@dirrmtry %%ETCDIR%%
@dirrmtry www/data