aboutsummaryrefslogtreecommitdiff
path: root/net/ruby-dict
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-10-22 20:16:59 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-10-22 20:16:59 +0000
commita4ac0e79aece241cf083779e917432fa6c67b8de (patch)
tree3a310bebdac2fb5318e1c9a63e4be65450689723 /net/ruby-dict
parentd09d472668ecb8a85fc72430206ae32a4783ff13 (diff)
downloadports-a4ac0e79aece241cf083779e917432fa6c67b8de.tar.gz
ports-a4ac0e79aece241cf083779e917432fa6c67b8de.zip
Add ruby-dict, a client-side implementation of the DICT protocol in
Ruby. PR: ports/43377 Submitted by: Kimura Fuyuki <fuyuki@hadaly.org>
Notes
Notes: svn path=/head/; revision=68605
Diffstat (limited to 'net/ruby-dict')
-rw-r--r--net/ruby-dict/Makefile35
-rw-r--r--net/ruby-dict/distinfo1
-rw-r--r--net/ruby-dict/pkg-comment1
-rw-r--r--net/ruby-dict/pkg-descr7
-rw-r--r--net/ruby-dict/pkg-plist6
5 files changed, 50 insertions, 0 deletions
diff --git a/net/ruby-dict/Makefile b/net/ruby-dict/Makefile
new file mode 100644
index 000000000000..bbc66243b19e
--- /dev/null
+++ b/net/ruby-dict/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Ruby/DICT
+# Date created: 26 September 2002
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dict
+PORTVERSION= 0.9.0
+CATEGORIES= net ruby
+MASTER_SITES= http://www.caliban.org/files/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= fuyuki@hadaly.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+RUBY_SHEBANG_FILES= ${WRKSRC}/rdict
+
+DOCS= README doc/dict.html doc/rdict.html
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/rdict ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ruby-dict/distinfo b/net/ruby-dict/distinfo
new file mode 100644
index 000000000000..c22e4ff94eb9
--- /dev/null
+++ b/net/ruby-dict/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-dict-0.9.0.tar.gz) = 1683cf7ea8fe23e7efe22a1995e06a4f
diff --git a/net/ruby-dict/pkg-comment b/net/ruby-dict/pkg-comment
new file mode 100644
index 000000000000..d573f48dc6bf
--- /dev/null
+++ b/net/ruby-dict/pkg-comment
@@ -0,0 +1 @@
+A client-side implementation of the DICT protocol in Ruby
diff --git a/net/ruby-dict/pkg-descr b/net/ruby-dict/pkg-descr
new file mode 100644
index 000000000000..b03171c860ee
--- /dev/null
+++ b/net/ruby-dict/pkg-descr
@@ -0,0 +1,7 @@
+Ruby/DICT is an RFC 2229 compliant client-side library implementation
+of the DICT protocol, written in the Ruby programming language. It
+can be used to write clients that access dictionary definitions from a
+set of natural language dictionary databases.
+
+Author: Ian Macdonald <ian@caliban.org>
+WWW: http://www.caliban.org/ruby/ruby-dict.shtml
diff --git a/net/ruby-dict/pkg-plist b/net/ruby-dict/pkg-plist
new file mode 100644
index 000000000000..2051845579a5
--- /dev/null
+++ b/net/ruby-dict/pkg-plist
@@ -0,0 +1,6 @@
+bin/rdict
+%%RUBY_SITELIBDIR%%/dict.rb
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/dict.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rdict.html
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%