aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-activestorage60
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-05 18:40:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-05 18:40:38 +0000
commite347b7b44d1bccb705716b6a6f9ffa76d2b4e9d7 (patch)
tree3998fc40332e9b2632ee23baea1d2d1ebe0a1e02 /net/rubygem-activestorage60
parent93b1cbd6fabfd6b1f929e63857ca3d2aeff8762a (diff)
downloadports-e347b7b44d1bccb705716b6a6f9ffa76d2b4e9d7.tar.gz
ports-e347b7b44d1bccb705716b6a6f9ffa76d2b4e9d7.zip
Add rubygem-activestorage60 6.0.2.1 (copied from rubygem-activestorage52)
Notes
Notes: svn path=/head/; revision=525322
Diffstat (limited to 'net/rubygem-activestorage60')
-rw-r--r--net/rubygem-activestorage60/Makefile30
-rw-r--r--net/rubygem-activestorage60/distinfo3
-rw-r--r--net/rubygem-activestorage60/pkg-descr14
3 files changed, 47 insertions, 0 deletions
diff --git a/net/rubygem-activestorage60/Makefile b/net/rubygem-activestorage60/Makefile
new file mode 100644
index 000000000000..acfdcd23cede
--- /dev/null
+++ b/net/rubygem-activestorage60/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= activestorage
+PORTVERSION= 6.0.2.1
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 60
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Attach cloud and local files in Rails applications
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+BROKEN_RUBY24= yes
+
+RUN_DEPENDS= rubygem-actionpack60>=${PORTVERSION}:www/rubygem-actionpack60 \
+ rubygem-activejob60>=${PORTVERSION}:devel/rubygem-activejob60 \
+ rubygem-activerecord60>=${PORTVERSION}:databases/rubygem-activerecord60 \
+ rubygem-marcel>=0.3.1<0.4:devel/rubygem-marcel
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.0\.
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-activestorage60/distinfo b/net/rubygem-activestorage60/distinfo
new file mode 100644
index 000000000000..6bab45d743cd
--- /dev/null
+++ b/net/rubygem-activestorage60/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577687174
+SHA256 (rubygem/activestorage-6.0.2.1.gem) = e88e5ae590df2fcf7fe3cf4bdd1822dc95841dd1c10fcb5fe26cb66799ce235a
+SIZE (rubygem/activestorage-6.0.2.1.gem) = 50688
diff --git a/net/rubygem-activestorage60/pkg-descr b/net/rubygem-activestorage60/pkg-descr
new file mode 100644
index 000000000000..192794021c2e
--- /dev/null
+++ b/net/rubygem-activestorage60/pkg-descr
@@ -0,0 +1,14 @@
+Active Storage makes it simple to upload and reference files in cloud services
+like Amazon S3, Google Cloud Storage, or Microsoft Azure Storage, and attach
+those files to Active Records. Supports having one main service and mirrors in
+other services for redundancy. It also provides a disk service for testing or
+local deployments, but the focus is on cloud storage.
+
+Files can be uploaded from the server to the cloud or directly from the client
+to the cloud.
+
+Image files can furthermore be transformed using on-demand variants for quality,
+aspect ratio, size, or any other MiniMagick or Vips supported transformation.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/activestorage