aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-bunny
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-24 11:50:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-24 11:50:59 +0000
commite19013d35563a0a3d58df0b5effb2786600cb8ca (patch)
treed6c0dd4aa167cc25313be114f5cebe1a15404e04 /net/rubygem-bunny
parent5ded53cdede553a01c2c1e9796fc44eb30bb8ac0 (diff)
downloadports-e19013d35563a0a3d58df0b5effb2786600cb8ca.tar.gz
ports-e19013d35563a0a3d58df0b5effb2786600cb8ca.zip
Bunny is an AMQP (Advanced Message Queuing Protocol) client, written in Ruby,
that is intended to allow you to interact with AMQP-compliant message brokers/servers such as RabbitMQ in a synchronous fashion. It is based on a great deal of useful code from amqp by Aman Gupta and Carrot by Amos Elliston. You can use Bunny to : * Create and delete exchanges * Create and delete queues * Publish and consume messages Bunny is known to work with RabbitMQ versions 1.5.4 and above with version 0-8 of the AMQP specification. WWW: http://github.com/celldee/bunny PR: ports/145841 Submitted by: renchap at cocoa-x.com
Notes
Notes: svn path=/head/; revision=253160
Diffstat (limited to 'net/rubygem-bunny')
-rw-r--r--net/rubygem-bunny/Makefile23
-rw-r--r--net/rubygem-bunny/distinfo3
-rw-r--r--net/rubygem-bunny/pkg-descr16
3 files changed, 42 insertions, 0 deletions
diff --git a/net/rubygem-bunny/Makefile b/net/rubygem-bunny/Makefile
new file mode 100644
index 000000000000..958f4ef08190
--- /dev/null
+++ b/net/rubygem-bunny/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: rubygem-bunny
+# Date created: 19 Mar 2010
+# Whom: renchap@cocoa-x.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= bunny
+PORTVERSION= 0.6.0
+CATEGORIES= net
+MASTER_SITES= http://gemcutter.org/gems/
+
+MAINTAINER= renchap@cocoa-x.com
+COMMENT= Another synchronous Ruby AMQP client
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+# we care about not passing -A to allow HTTP redirect
+FETCH_ARGS= -pRr
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-bunny/distinfo b/net/rubygem-bunny/distinfo
new file mode 100644
index 000000000000..145cedb99fdc
--- /dev/null
+++ b/net/rubygem-bunny/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/bunny-0.6.0.gem) = 1697fe4ec6f17826b823ae86adc92098
+SHA256 (rubygem/bunny-0.6.0.gem) = fb8142488e96124f1b880979d1006366f254323f555add01a028ef70db306038
+SIZE (rubygem/bunny-0.6.0.gem) = 32256
diff --git a/net/rubygem-bunny/pkg-descr b/net/rubygem-bunny/pkg-descr
new file mode 100644
index 000000000000..299e1594296f
--- /dev/null
+++ b/net/rubygem-bunny/pkg-descr
@@ -0,0 +1,16 @@
+Bunny is an AMQP (Advanced Message Queuing Protocol) client, written in Ruby,
+that is intended to allow you to interact with AMQP-compliant message
+brokers/servers such as RabbitMQ in a synchronous fashion.
+
+It is based on a great deal of useful code from amqp by Aman Gupta and Carrot
+by Amos Elliston.
+
+You can use Bunny to :
+* Create and delete exchanges
+* Create and delete queues
+* Publish and consume messages
+
+Bunny is known to work with RabbitMQ versions 1.5.4 and above with version 0-8
+of the AMQP specification.
+
+WWW: http://github.com/celldee/bunny