aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-fog-aliyun/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-27 15:47:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-27 15:47:56 +0000
commit90d934559eb587872ab6135f55673af638ba0bd5 (patch)
treec73576b1c2db7eae53e091eea68a9b529d111125 /net/rubygem-fog-aliyun/Makefile
parentfd81aa8bd27d78f577f8f3c9dde5850afd5ebeb7 (diff)
downloadports-90d934559eb587872ab6135f55673af638ba0bd5.tar.gz
ports-90d934559eb587872ab6135f55673af638ba0bd5.zip
- Add rubygem-fog-aliyun 0.0.10
Fog::Aliyun is a module for the fog gem to support aliyun OSS/ECS. WWW: https://github.com/fog/fog-aliyun
Notes
Notes: svn path=/head/; revision=400251
Diffstat (limited to 'net/rubygem-fog-aliyun/Makefile')
-rw-r--r--net/rubygem-fog-aliyun/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net/rubygem-fog-aliyun/Makefile b/net/rubygem-fog-aliyun/Makefile
new file mode 100644
index 000000000000..eb3de6c5ca85
--- /dev/null
+++ b/net/rubygem-fog-aliyun/Makefile
@@ -0,0 +1,25 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fog-aliyun
+PORTVERSION= 0.0.10
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Module for the 'fog' gem to support aliyun OSS/ECS
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-fog-core>=1.27:${PORTSDIR}/devel/rubygem-fog-core \
+ rubygem-fog-json>=1.0:${PORTSDIR}/devel/rubygem-fog-json \
+ rubygem-ipaddress>=0.8:${PORTSDIR}/net/rubygem-ipaddress \
+ rubygem-xml-simple>=1.1:${PORTSDIR}/textproc/rubygem-xml-simple
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>