aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-gitlab_omniauth-ldap/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-10-25 02:28:44 +0000
committerSteve Wills <swills@FreeBSD.org>2013-10-25 02:28:44 +0000
commitcb909b8fa172fe60a8cc516bba6e0de63ea87008 (patch)
tree3950ac9487e3b2576d6e4738d157752a961d5b9a /net/rubygem-gitlab_omniauth-ldap/Makefile
parentd80e36add022e0603fdb07d7f62f06423fc16909 (diff)
downloadports-cb909b8fa172fe60a8cc516bba6e0de63ea87008.tar.gz
ports-cb909b8fa172fe60a8cc516bba6e0de63ea87008.zip
A LDAP strategy for OmniAuth.
WWW: https://github.com/gitlabhq/omniauth-ldap PR: ports/182766 Submitted by: Loic Blot <loic.blot@unix-experience.fr>
Notes
Notes: svn path=/head/; revision=331546
Diffstat (limited to 'net/rubygem-gitlab_omniauth-ldap/Makefile')
-rw-r--r--net/rubygem-gitlab_omniauth-ldap/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/rubygem-gitlab_omniauth-ldap/Makefile b/net/rubygem-gitlab_omniauth-ldap/Makefile
new file mode 100644
index 000000000000..39c2f3b2864b
--- /dev/null
+++ b/net/rubygem-gitlab_omniauth-ldap/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= gitlab_omniauth-ldap
+PORTVERSION= 1.0.3
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= A LDAP strategy for OmniAuth.
+
+RUN_DEPENDS= rubygem-net-ldap>=0.3.1:${PORTSDIR}/net/rubygem-net-ldap \
+ rubygem-omniauth>=1.0:${PORTSDIR}/security/rubygem-omniauth \
+ rubygem-pyu-ruby-sasl>=0.0.3.1:${PORTSDIR}/security/rubygem-pyu-ruby-sasl \
+ rubygem-rubyntlm>=0.1.1:${PORTSDIR}/net/rubygem-rubyntlm
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>