aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-google-cloud-logging-v2/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-10-09 14:19:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-10-09 14:19:30 +0000
commite1d1263c9090a4c84e0d19fb0fa9443341827b60 (patch)
tree3d1689672f506765b99619b3bdd5a9a8ef1136fb /net/rubygem-google-cloud-logging-v2/Makefile
parentd558c53a23565aeb1c7028efa7545cde1e0cb8bc (diff)
downloadports-e1d1263c9090a4c84e0d19fb0fa9443341827b60.tar.gz
ports-e1d1263c9090a4c84e0d19fb0fa9443341827b60.zip
Add rubygem-google-cloud-logging-v2 0.1.3
API Client library for the Cloud Logging V2 API The Cloud Logging API lets you programmatically read and write log entries, set up exclusions, create logs-based metrics, and manage export sinks. WWW: https://github.com/googleapis/google-cloud-ruby WWW: https://github.com/googleapis/google-cloud-ruby/tree/master/google-cloud-logging-v2
Notes
Notes: svn path=/head/; revision=551774
Diffstat (limited to 'net/rubygem-google-cloud-logging-v2/Makefile')
-rw-r--r--net/rubygem-google-cloud-logging-v2/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net/rubygem-google-cloud-logging-v2/Makefile b/net/rubygem-google-cloud-logging-v2/Makefile
new file mode 100644
index 000000000000..20af1003b3f2
--- /dev/null
+++ b/net/rubygem-google-cloud-logging-v2/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= google-cloud-logging-v2
+PORTVERSION= 0.1.3
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby Client for the Cloud Logging V2 API
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-gapic-common>=0.3<1:devel/rubygem-gapic-common \
+ rubygem-google-cloud-errors>=1.0<2:net/rubygem-google-cloud-errors
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>