aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-omniauth-oauth2
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-10-21 01:40:12 +0000
committerSteve Wills <swills@FreeBSD.org>2013-10-21 01:40:12 +0000
commit6f220ed4e6ebffeaf45ae2e3d5a5bce8bfbc5ad4 (patch)
tree3e34bc27c13f1e2c8e364ed3dbdcab0b1806b9d3 /net/rubygem-omniauth-oauth2
parent0a012ec015521ad5ced2e86f4a12dbf94691c1db (diff)
downloadports-6f220ed4e6ebffeaf45ae2e3d5a5bce8bfbc5ad4.tar.gz
ports-6f220ed4e6ebffeaf45ae2e3d5a5bce8bfbc5ad4.zip
An abstract OAuth2 strategy for OmniAuth.
WWW: https://rubygems.org/gems/omniauth-oauth2 PR: ports/182698 Submitted by: Loic Blot <loic.blot@unix-experience.fr>
Notes
Notes: svn path=/head/; revision=331079
Diffstat (limited to 'net/rubygem-omniauth-oauth2')
-rw-r--r--net/rubygem-omniauth-oauth2/Makefile20
-rw-r--r--net/rubygem-omniauth-oauth2/distinfo2
-rw-r--r--net/rubygem-omniauth-oauth2/files/patch-oauth2-ver31
-rw-r--r--net/rubygem-omniauth-oauth2/pkg-descr3
4 files changed, 56 insertions, 0 deletions
diff --git a/net/rubygem-omniauth-oauth2/Makefile b/net/rubygem-omniauth-oauth2/Makefile
new file mode 100644
index 000000000000..721f97f05b48
--- /dev/null
+++ b/net/rubygem-omniauth-oauth2/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= omniauth-oauth2
+PORTVERSION= 1.1.1
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Abstract OAuth2 strategy for OmniAuth
+
+RUN_DEPENDS= rubygem-oauth2>=0.8.0:${PORTSDIR}/net/rubygem-oauth2 \
+ rubygem-omniauth>=1.0:${PORTSDIR}/security/rubygem-omniauth
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-oauth2/distinfo b/net/rubygem-omniauth-oauth2/distinfo
new file mode 100644
index 000000000000..8d9e07f92759
--- /dev/null
+++ b/net/rubygem-omniauth-oauth2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/omniauth-oauth2-1.1.1.gem) = 72b8ba77b9ead4320e7f4e430aee0f3ef759aed79ae52c3b0e8fb2f41785eb68
+SIZE (rubygem/omniauth-oauth2-1.1.1.gem) = 7680
diff --git a/net/rubygem-omniauth-oauth2/files/patch-oauth2-ver b/net/rubygem-omniauth-oauth2/files/patch-oauth2-ver
new file mode 100644
index 000000000000..56d53d482796
--- /dev/null
+++ b/net/rubygem-omniauth-oauth2/files/patch-oauth2-ver
@@ -0,0 +1,31 @@
+--- omniauth-oauth2-1.1.1.gemspec.orig 2013-10-20 23:55:59.202502414 +0000
++++ omniauth-oauth2-1.1.1.gemspec 2013-10-20 23:56:22.411500458 +0000
+@@ -34,7 +34,7 @@
+ requirements:
+ - - ~>
+ - !ruby/object:Gem::Version
+- version: 0.8.0
++ version: 0.9.0
+ type: :runtime
+ prerelease: false
+ version_requirements: !ruby/object:Gem::Requirement
+@@ -42,7 +42,7 @@
+ requirements:
+ - - ~>
+ - !ruby/object:Gem::Version
+- version: 0.8.0
++ version: 0.9.0
+ - !ruby/object:Gem::Dependency
+ name: rspec
+ requirement: !ruby/object:Gem::Requirement
+--- omniauth-oauth2.gemspec.orig 2013-10-20 23:56:06.122501604 +0000
++++ omniauth-oauth2.gemspec 2013-10-20 23:56:27.040820651 +0000
+@@ -3,7 +3,7 @@
+
+ Gem::Specification.new do |gem|
+ gem.add_dependency 'omniauth', '~> 1.0'
+- gem.add_dependency 'oauth2', '~> 0.8.0'
++ gem.add_dependency 'oauth2', '~> 0.9.0'
+
+ gem.add_development_dependency 'rspec', '~> 2.7'
+ gem.add_development_dependency 'rack-test'
diff --git a/net/rubygem-omniauth-oauth2/pkg-descr b/net/rubygem-omniauth-oauth2/pkg-descr
new file mode 100644
index 000000000000..d591e6c3c944
--- /dev/null
+++ b/net/rubygem-omniauth-oauth2/pkg-descr
@@ -0,0 +1,3 @@
+An abstract OAuth2 strategy for OmniAuth.
+
+WWW: https://rubygems.org/gems/omniauth-oauth2