aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-rightflexiscale/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-04-23 21:21:34 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-04-23 21:21:34 +0000
commitfdca9b7f02fb48609586b7f3dc0f7224285838e0 (patch)
treeb5eb14d4af47d643943d312de15d67c11be620e8 /net/rubygem-rightflexiscale/Makefile
parenta8d9f08b6812629212e71c7a1bbfb9728e535991 (diff)
downloadports-fdca9b7f02fb48609586b7f3dc0f7224285838e0.tar.gz
ports-fdca9b7f02fb48609586b7f3dc0f7224285838e0.zip
The RightScale Flexiscale gem has been designed to provide a robust
interface to Flexiscale's existing API. WWW: http://rightaws.rubyforge.org/
Notes
Notes: svn path=/head/; revision=232619
Diffstat (limited to 'net/rubygem-rightflexiscale/Makefile')
-rw-r--r--net/rubygem-rightflexiscale/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/rubygem-rightflexiscale/Makefile b/net/rubygem-rightflexiscale/Makefile
new file mode 100644
index 000000000000..e80609cbf335
--- /dev/null
+++ b/net/rubygem-rightflexiscale/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: rubygem-rightflexiscale
+# Date created: 23 Apr 2009
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rightflexiscale
+PORTVERSION= 0.1.0
+CATEGORIES= net rubygems
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= rightscale
+DISTNAME= right_flexiscale-${PORTVERSION}
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Provides Ruby access to the Flexiscale API
+
+RUN_DEPENDS= rubygem-righthttpconnection>=1.2.4:${PORTSDIR}/net/rubygem-righthttpconnection \
+ rubygem-soap4r>=1.5.8:${PORTSDIR}/devel/rubygem-soap4r
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+GEM_NAME= ${DISTNAME}
+RUBYGEM_AUTOPLIST= yes
+UNIQUENAME= ${PORTNAME}
+
+.include <bsd.port.mk>