aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-tweetstream/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2010-11-23 00:12:21 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2010-11-23 00:12:21 +0000
commitc5f8c5a2ce4249c9e7f4bf08bf5799ac02f88767 (patch)
tree352e643b48e977786ca83a2769e4544d417ea0f6 /net/rubygem-tweetstream/Makefile
parent66828f0bdf5dd7570eca26609f0cb73110a762b5 (diff)
downloadports-c5f8c5a2ce4249c9e7f4bf08bf5799ac02f88767.tar.gz
ports-c5f8c5a2ce4249c9e7f4bf08bf5799ac02f88767.zip
- Add a new port: net/rubygem-tweetstream
TweetStream provides simple Ruby access to Twitter's Streaming API WWW: http://github.com/intridea/tweetstream
Notes
Notes: svn path=/head/; revision=264952
Diffstat (limited to 'net/rubygem-tweetstream/Makefile')
-rw-r--r--net/rubygem-tweetstream/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/net/rubygem-tweetstream/Makefile b/net/rubygem-tweetstream/Makefile
new file mode 100644
index 000000000000..7423cf93abc5
--- /dev/null
+++ b/net/rubygem-tweetstream/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: rubygem-tweetstream
+# Date created: 2010-11-17
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tweetstream
+PORTVERSION= 1.0.4
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= TweetStream provides simple Ruby access to Twitter\'s Streaming API
+
+RUN_DEPENDS= rubygem-twitter-stream>=0.0:${PORTSDIR}/net/rubygem-twitter-stream \
+ rubygem-daemons>=0.0.0:${PORTSDIR}/devel/rubygem-daemons \
+ rubygem-json>=0.0.0:${PORTSDIR}/devel/rubygem-json
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+OPTIONS= JSON_PURE "JSON implementation in pure Ruby support" Off \
+ ACTIVESUPPORT "ActiveSupport::JSON.decode support" Off \
+ YAJL_RUBY "yajl-ruby support" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_JSON_PURE)
+RUN_DEPENDS+= rubygem-json_pure>=0:${PORTSDIR}/devel/rubygem-json_pure
+.endif
+
+.if defined(WITH_ACTIVESUPPORT)
+RUN_DEPENDS+= rubygem-activesupport>=0:${PORTSDIR}/devel/rubygem-activesupport
+.endif
+
+.if defined(WITH_YAJL_RUBY)
+RUN_DEPENDS+= rubygem-yajl-ruby>=0:${PORTSDIR}/devel/rubygem-yajl-ruby
+.endif
+
+.include <bsd.port.mk>