aboutsummaryrefslogtreecommitdiff
path: root/net/rwhoisd
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-04 16:39:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-04 16:39:59 +0000
commitf727c781798208462b5a54e746616851147519b6 (patch)
treeac6c8671f3dfcd0ce333692fd2275d1856f92cc2 /net/rwhoisd
parent1bbc8b4b34614d4f8b647105500fb9123e667c9a (diff)
downloadports-f727c781798208462b5a54e746616851147519b6.tar.gz
ports-f727c781798208462b5a54e746616851147519b6.zip
- Switch to options helpers
- Silence stripping - Remove LARGEFILES option - it does nothing on FreeBSD and is not in fact needed
Notes
Notes: svn path=/head/; revision=408056
Diffstat (limited to 'net/rwhoisd')
-rw-r--r--net/rwhoisd/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/net/rwhoisd/Makefile b/net/rwhoisd/Makefile
index ad53cee1c867..e62e154e0667 100644
--- a/net/rwhoisd/Makefile
+++ b/net/rwhoisd/Makefile
@@ -30,20 +30,10 @@ ETCFILES= rwhoisd.allow rwhoisd.auth_area rwhoisd.conf rwhoisd.deny \
rwhoisd.dir rwhoisd.root rwhoisd.x.dir
PLIST_SUB+= ETCFILES="${ETCFILES}"
-OPTIONS_DEFINE= IPV6 LARGEFILE DOCS
-OPTIONS_DEFAULT= IPV6
+OPTIONS_DEFINE= IPV6 DOCS
+OPTIONS_DEFAULT=IPV6
IPV6_DESC= Enable IPV6 support
-LARGEFILE_DESC= Enable largefile support (> 2Gb)
-
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MIPV6)
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
-
-.if ${PORT_OPTIONS:MLARGEFILE}
-CONFIGURE_ARGS+= --enable-largefile
-.endif
+IPV6_CONFIGURE_OFF= --disable-ipv6
post-patch:
@${REINPLACE_CMD} -e 's,userid: rwhoisd,userid: nobody,' \
@@ -53,13 +43,15 @@ post-patch:
${WRKSRC}/common/conf.h
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/*
${INSTALL_MAN} ${WRKSRC}/doc/rwhois_indexer.8 ${STAGEDIR}${PREFIX}/man/man8
${INSTALL_MAN} ${WRKSRC}/doc/rwhoisd.8 ${STAGEDIR}${PREFIX}/man/man8
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-. for f in ${PORTDOCS}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
-. endfor
+.endfor
.include <bsd.port.mk>