aboutsummaryrefslogtreecommitdiff
path: root/net/samba3
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:48:57 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:48:57 +0000
commit897d06aa9731645e0a7fa7c315028dcdbfa3c798 (patch)
tree485cefa9621a788f5d27ac4dcab7fc6aa9843be6 /net/samba3
parentc982f5faf1c27ba011ef14e71aadc2182660d704 (diff)
downloadports-897d06aa9731645e0a7fa7c315028dcdbfa3c798.tar.gz
ports-897d06aa9731645e0a7fa7c315028dcdbfa3c798.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Notes
Notes: svn path=/head/; revision=53958
Diffstat (limited to 'net/samba3')
-rw-r--r--net/samba3/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index d6bd4af498b1..a400d2dc0330 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -103,10 +103,10 @@ post-install:
${CHOWN} root:wheel ${PREFIX}/bin/smbpasswd
${CHMOD} 111 ${PREFIX}/bin/smbpasswd
.if defined(PACKAGE_BUILDING)
- ${ECHO} "private/smbpasswd" >> ${TMPPLIST}
- ${ECHO} "@dirrm private" >> ${TMPPLIST}
+ ${ECHO_CMD} "private/smbpasswd" >> ${TMPPLIST}
+ ${ECHO_CMD} "@dirrm private" >> ${TMPPLIST}
.else
- ${ECHO} "@unexec ${ECHO} \"Warning: If you will *NOT* use this package anymore, please remove %D/private/smbpasswd manually.\"" >> ${TMPPLIST}
+ ${ECHO_CMD} "@unexec ${ECHO_CMD} \"Warning: If you will *NOT* use this package anymore, please remove %D/private/smbpasswd manually.\"" >> ${TMPPLIST}
.endif
.if !defined(NOPORTDOCS)