aboutsummaryrefslogtreecommitdiff
path: root/net/sctplib
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-08-18 11:11:21 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-08-18 11:11:21 +0000
commitef4871d43fa0e88001c61e2428f206e76e22a18b (patch)
tree6f5d1542ee665fdd770c65992013efcd49f38098 /net/sctplib
parent80a9e9324960519f13a0e44159e11d6006d3aae4 (diff)
downloadports-ef4871d43fa0e88001c61e2428f206e76e22a18b.tar.gz
ports-ef4871d43fa0e88001c61e2428f206e76e22a18b.zip
New port: net/sctplib
The SCTPLIB library is a prototype implementation of the Stream Control Transmission Protocol (SCTP), a message-oriented reliable transport protocol that supports multi-homing, and multiple message streams multiplexed within an SCTP connection (also named association). SCTP is described in RFC 4960. See https://www.uni-due.de/~be0001/sctplib/ for details. The API of the library is modeled after Section 10 of RFC 4960, and most parameters and functions should be self-explanatory to the user familiar with this document. In addition to these interface functions between an Upper Layer Protocol (ULP) and an SCTP instance, the library also provides a number of helper functions that can be used to manage callbacks and timers, as well as UDP sockets for simple IPC. Furthermore, SCTPLIB provides support for UDP encapsulation, making it possible to co-exist with kernel SCTP implementations. WWW: https://www.uni-due.de/~be0001/sctplib/ PR: 239844 Submitted by: dreibh@iem.uni-due.de
Notes
Notes: svn path=/head/; revision=509201
Diffstat (limited to 'net/sctplib')
-rw-r--r--net/sctplib/Makefile28
-rw-r--r--net/sctplib/distinfo3
-rw-r--r--net/sctplib/pkg-descr14
3 files changed, 45 insertions, 0 deletions
diff --git a/net/sctplib/Makefile b/net/sctplib/Makefile
new file mode 100644
index 000000000000..d48778d32aab
--- /dev/null
+++ b/net/sctplib/Makefile
@@ -0,0 +1,28 @@
+# Created by: Thomas Dreibholz <dreibh@iem.uni-due.de>
+# $FreeBSD$
+
+PORTNAME= sctplib
+PORTVERSION= 1.0.24
+CATEGORIES= net
+MASTER_SITES= https://www.uni-due.de/~be0001/sctplib/download/
+
+MAINTAINER= dreibh@iem.uni-due.de
+COMMENT= User-space implementation of the SCTP protocol RFC 4960
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gnome libtool pkgconfig
+USE_LDCONFIG= yes
+USE_GNOME= glib20
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-sctp-over-udp
+INSTALL_TARGET= install-strip
+PLIST_FILES= include/sctp.h \
+ lib/libsctplib.a \
+ lib/libsctplib.so \
+ lib/libsctplib.so.1 \
+ lib/libsctplib.so.1.0.8
+
+.include <bsd.port.mk>
diff --git a/net/sctplib/distinfo b/net/sctplib/distinfo
new file mode 100644
index 000000000000..8a80b41bc56b
--- /dev/null
+++ b/net/sctplib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565784282
+SHA256 (sctplib-1.0.24.tar.gz) = 82ce014e51b4405cdc3dc691ae5fa66ee861205e0c91426d5c9af18866f91046
+SIZE (sctplib-1.0.24.tar.gz) = 1037978
diff --git a/net/sctplib/pkg-descr b/net/sctplib/pkg-descr
new file mode 100644
index 000000000000..f66a89df4c4f
--- /dev/null
+++ b/net/sctplib/pkg-descr
@@ -0,0 +1,14 @@
+The SCTPLIB library is a prototype implementation of the Stream Control
+Transmission Protocol (SCTP), a message-oriented reliable transport protocol
+that supports multi-homing, and multiple message streams multiplexed within an
+SCTP connection (also named association). SCTP is described in RFC 4960. See
+https://www.uni-due.de/~be0001/sctplib/ for details. The API of the library is
+modeled after Section 10 of RFC 4960, and most parameters and functions should
+be self-explanatory to the user familiar with this document. In addition to
+these interface functions between an Upper Layer Protocol (ULP) and an SCTP
+instance, the library also provides a number of helper functions that can be
+used to manage callbacks and timers, as well as UDP sockets for simple IPC.
+Furthermore, SCTPLIB provides support for UDP encapsulation, making it possible
+to co-exist with kernel SCTP implementations.
+
+WWW: https://www.uni-due.de/~be0001/sctplib/