aboutsummaryrefslogtreecommitdiff
path: root/net/ser
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2007-08-15 18:35:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2007-08-15 18:35:05 +0000
commitdbecc08e70b31d5973827d18f20946a492b96112 (patch)
tree929a30a5163bad2b2668a15ff56d2e2bd7bfaa27 /net/ser
parent15f99e66623c2aa986f86017a8fdf348540ae142 (diff)
downloadports-dbecc08e70b31d5973827d18f20946a492b96112.tar.gz
ports-dbecc08e70b31d5973827d18f20946a492b96112.zip
Add startup script. Bump PORTREVISION.
Submitted by: Blaz Zupan
Notes
Notes: svn path=/head/; revision=197767
Diffstat (limited to 'net/ser')
-rw-r--r--net/ser/Makefile3
-rw-r--r--net/ser/files/ser.in34
2 files changed, 36 insertions, 1 deletions
diff --git a/net/ser/Makefile b/net/ser/Makefile
index cf848f191352..eb3ed6ad0fee 100644
--- a/net/ser/Makefile
+++ b/net/ser/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ser
PORTVERSION= 0.9.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= http://download.berlios.de/ser/ \
http://download2.berlios.de/ser/
@@ -19,6 +19,7 @@ COMMENT= A very fast and configurable SIP proxy
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
+USE_RC_SUBR= ser
CFLAGS+= -I${LOCALBASE}/include
MAKE_ENV+= "LDFLAGS=-L${LOCALBASE}/lib"
diff --git a/net/ser/files/ser.in b/net/ser/files/ser.in
new file mode 100644
index 000000000000..73c5f277ad77
--- /dev/null
+++ b/net/ser/files/ser.in
@@ -0,0 +1,34 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: ser
+# REQUIRE: DAEMON mysql postgresql
+#
+prefix=%%PREFIX%%
+
+# Add the following lines to /etc/rc.conf to enable ser:
+#
+# ser_enable="YES"
+
+. %%RC_SUBR%%
+
+name="ser"
+rcvar=`set_rcvar`
+command="${prefix}/sbin/${name}"
+pidfile="/var/run/${name}.pid"
+command_args="-P ${pidfile} > /dev/null"
+
+load_rc_config $name
+
+: ${ser_enable="NO"}
+
+stop_postcmd=stop_postcmd
+
+stop_postcmd()
+{
+ rm -f $pidfile
+}
+
+run_rc_command "$1"