aboutsummaryrefslogtreecommitdiff
path: root/net/sie-nmsg
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-07 11:17:35 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-07 11:17:35 +0000
commitc32c356c4abef1d655dd7057f489d146a282d6af (patch)
treee017d8a0dafb681a30f32e921565b215b67cc1b9 /net/sie-nmsg
parentaa961f501b5112c86d7527a10961812b43074844 (diff)
downloadports-c32c356c4abef1d655dd7057f489d146a282d6af.tar.gz
ports-c32c356c4abef1d655dd7057f489d146a282d6af.zip
Add new port net/sie-nmsg
PR: 190731 Submitted by: Don Lewis (truckman@) ================================================================ This package extends the libnmsg runtime <net/nmsg> to support the following message types: SIE/dnsdedupe SIE/newdomain SIE/qr SIE/reputation SIE/delay
Notes
Notes: svn path=/head/; revision=364264
Diffstat (limited to 'net/sie-nmsg')
-rw-r--r--net/sie-nmsg/Makefile23
-rw-r--r--net/sie-nmsg/distinfo2
-rw-r--r--net/sie-nmsg/pkg-descr10
-rw-r--r--net/sie-nmsg/pkg-plist9
4 files changed, 44 insertions, 0 deletions
diff --git a/net/sie-nmsg/Makefile b/net/sie-nmsg/Makefile
new file mode 100644
index 000000000000..41fff2388a6c
--- /dev/null
+++ b/net/sie-nmsg/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= sie-nmsg
+PORTVERSION= 0.16
+CATEGORIES= net dns
+MASTER_SITES= https://dl.farsightsecurity.com/dist/sie-nmsg/
+
+MAINTAINER= truckman@FreeBSD.org
+COMMENT= SIE message module plugin for libnmsg
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libprotobuf-c.so:${PORTSDIR}/devel/protobuf-c \
+ libnmsg.so:${PORTSDIR}/net/nmsg \
+ libwdns.so:${PORTSDIR}/dns/wdns
+
+GNU_CONFIGURE= yes
+USES= gmake libtool pathfix pkgconfig
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/nmsg/nmsg_msg8_sie.so
+
+.include <bsd.port.mk>
diff --git a/net/sie-nmsg/distinfo b/net/sie-nmsg/distinfo
new file mode 100644
index 000000000000..da350880841c
--- /dev/null
+++ b/net/sie-nmsg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sie-nmsg-0.16.tar.gz) = ead7937cdbd1d8963bb9bf6ec5bdb3773fe299b6f4296bf76d7c833612fcdbe4
+SIZE (sie-nmsg-0.16.tar.gz) = 313527
diff --git a/net/sie-nmsg/pkg-descr b/net/sie-nmsg/pkg-descr
new file mode 100644
index 000000000000..2dc87d76c625
--- /dev/null
+++ b/net/sie-nmsg/pkg-descr
@@ -0,0 +1,10 @@
+This package extends the libnmsg runtime <net/nmsg> to support the
+following message types:
+
+SIE/dnsdedupe
+SIE/newdomain
+SIE/qr
+SIE/reputation
+SIE/delay
+
+WWW: https://github.com/farsightsec/sie-nmsg
diff --git a/net/sie-nmsg/pkg-plist b/net/sie-nmsg/pkg-plist
new file mode 100644
index 000000000000..fbc0532c3c88
--- /dev/null
+++ b/net/sie-nmsg/pkg-plist
@@ -0,0 +1,9 @@
+include/nmsg/sie/defs.h
+include/nmsg/sie/delay.pb-c.h
+include/nmsg/sie/dnsdedupe.pb-c.h
+include/nmsg/sie/newdomain.pb-c.h
+include/nmsg/sie/qr.pb-c.h
+include/nmsg/sie/reputation.pb-c.h
+lib/nmsg/nmsg_msg8_sie.a
+lib/nmsg/nmsg_msg8_sie.so
+@dirrmtry include/nmsg/sie