aboutsummaryrefslogtreecommitdiff
path: root/net/silc-client
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-11-19 16:22:34 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-11-19 16:22:34 +0000
commitcd26f609a1b16c4ccaaa1f8b2550b859db944999 (patch)
treee2c94e758707ca025bf8ba4e1b35e80d555dd9f2 /net/silc-client
parentdf09a873dcc6e94956b508a1e94f3c4af2e3457f (diff)
downloadports-cd26f609a1b16c4ccaaa1f8b2550b859db944999.tar.gz
ports-cd26f609a1b16c4ccaaa1f8b2550b859db944999.zip
Convert to new options.
Avoid using != in assignment. Feature safe: yes
Notes
Notes: svn path=/head/; revision=307565
Diffstat (limited to 'net/silc-client')
-rw-r--r--net/silc-client/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index 70034acad481..fa7cdb5e7e54 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -34,11 +34,10 @@ CONFIGURE_ARGS= --docdir=${DOCSDIR} \
--without-libtoolfix
WANT_PERL= yes
-OPTIONS= PTHREADS "Enable pthreads support" off \
- IPV6 "Enable IPv6 support" on \
- ICONV "Enable international character support" on \
- PERL "Enable perl support" on \
- OPTIMIZED_ASM "Use assembler optimizations (i386 only)" on
+OPTIONS_DEFINE= PTHREADS IPV6 ICONV PERL OPTIMIZED_ASM
+PTHREADS_DESC= "Enable pthreads support"
+OPTIMIZED_ASM_DESC= "Use assembler optimizations (i386 only)"
+OPTIONS_DEFAULT= IPV6 ICONV PERL OPTIMIZED_ASM
.ifdef(IRSSI_PLUGIN)
CONFIGURE_ARGS+= --with-silc-plugin=${PREFIX}/lib/irssi \
@@ -83,41 +82,40 @@ post-install:
fi
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} != "i386"
WITHOUT_OPTIMIZED_ASM= yes
.endif
-.if defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if defined(WITH_ICONV)
+.if ${PORT_OPTIONS:MICONV}
USE_ICONV= yes
CONFIGURE_ARGS+= --with-iconv
.else
CONFIGURE_ARGS+= --without-iconv
.endif
-.if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
USE_PERL5= yes
-PERL_ARCHNAME!= ${PERL} -V:archname 2>/dev/null || true
-PLIST_SUB+= WITH_PERL="" PERL_ARCHNAME=${PERL_ARCHNAME:S/archname='//:S/';//}
+PLIST_SUB+= WITH_PERL="" PERL_ARCHNAME="${ARCH}-freebsd"
CONFIGURE_ARGS+= --with-perl-lib=${PREFIX}/lib/${PORTNAME}/perl
.else
CONFIGURE_ARGS+= --without-perl
PLIST_SUB+= WITH_PERL="@comment "
.endif
-.if defined(WITHOUT_OPTIMIZED_ASM)
+.if ${PORT_OPTIONS:MOPTIMIZED_ASM}
CONFIGURE_ARGS+= --disable-asm
.endif
-.if defined(WITH_PTHREADS)
+.if ${PORT_OPTIONS:MPTHREADS}
CFLAGS+= ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}
.else
CONFIGURE_ARGS+= --without-pthreads
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>