aboutsummaryrefslogtreecommitdiff
path: root/net/sniffit
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-08-17 07:25:18 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-08-17 07:25:18 +0000
commit8f6a263ee7893b8982794413bec5a2992e01d4bf (patch)
treeefc4c24dbc0b2eb71d8bd4a163842959204ddfa1 /net/sniffit
parent23ccf010b7a7054a56ad1019825b49405fa9dd62 (diff)
downloadports-8f6a263ee7893b8982794413bec5a2992e01d4bf.tar.gz
ports-8f6a263ee7893b8982794413bec5a2992e01d4bf.zip
upgrade to 0.3.7.beta
Notes
Notes: svn path=/head/; revision=12570
Diffstat (limited to 'net/sniffit')
-rw-r--r--net/sniffit/Makefile6
-rw-r--r--net/sniffit/distinfo2
-rw-r--r--net/sniffit/files/patch-0125
-rw-r--r--net/sniffit/files/patch-0242
-rw-r--r--net/sniffit/files/patch-0321
5 files changed, 38 insertions, 58 deletions
diff --git a/net/sniffit/Makefile b/net/sniffit/Makefile
index 3cda8a057276..7d8e43c0c111 100644
--- a/net/sniffit/Makefile
+++ b/net/sniffit/Makefile
@@ -4,11 +4,11 @@
# Date created: 28 Mar 1998
# Whom: bsdx
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/04/04 04:58:25 obrien Exp $
#
-DISTNAME= sniffit.0.3.5
-PKGNAME= sniffit-0.3.5
+DISTNAME= sniffit.0.3.7.beta
+PKGNAME= sniffit-0.3.7b
CATEGORIES= net security
MASTER_SITES= http://reptile.rug.ac.be/~coder/sniffit/files/
diff --git a/net/sniffit/distinfo b/net/sniffit/distinfo
index c455648e4d74..a89a487af2ca 100644
--- a/net/sniffit/distinfo
+++ b/net/sniffit/distinfo
@@ -1 +1 @@
-MD5 (sniffit.0.3.5.tar.gz) = bd116c62669372d7ea7f59c337f6822a
+MD5 (sniffit.0.3.7.beta.tar.gz) = 2697cc18878480199fe6db1e61134d5a
diff --git a/net/sniffit/files/patch-01 b/net/sniffit/files/patch-01
index 441ca016d5e7..b2aab77d5068 100644
--- a/net/sniffit/files/patch-01
+++ b/net/sniffit/files/patch-01
@@ -1,26 +1,25 @@
---- Makefile.in.orig Fri Apr 18 17:33:57 1997
-+++ Makefile.in Wed Jul 1 20:17:08 1998
+--- Makefile.in.orig Thu Jul 16 09:17:10 1998
++++ Makefile.in Sun Aug 16 23:20:29 1998
@@ -10,10 +10,10 @@
LIBS = @LIBS@
DEFS = @DEFS@
OS_OPT = @OS_OPT@
-OBJ_FLAG = -w -O2 -c
--OBJ_OPT = -I./libpcap-0.3 -L./libpcap-0.3
+-OBJ_OPT = -I./libpcap -L./libpcap
-EXE_FLAG = -w -O2 -o sniffit
--EXE_OPT = -I./libpcap-0.3 -L./libpcap-0.3 -lpcap
-+OBJ_FLAG = ${CFLAGS} -w -c
-+#OBJ_OPT = -I./libpcap-0.3 -L./libpcap-0.3
-+EXE_FLAG = ${CFLAGS} -w -o sniffit
+-EXE_OPT = -I./libpcap -L./libpcap -lpcap
++OBJ_FLAG = $(CFLAGS) -w -c
++#OBJ_OPT = -I./libpcap -L./libpcap
++EXE_FLAG = $(CFLAGS) -w -o sniffit
+EXE_OPT = -lpcap
EXE_OBJ = sn_packets.o sn_generation.o sn_interface.o sn_cfgfile.o \
- sn_logfile.o
- DEP_FILES = sn_config.h pcap.h sn_data.h sn_defines.h sn_plugins.h \
-@@ -21,7 +21,7 @@
- sn_generation.o sn_interface.o sn_cfgfile.o sn_logfile.o
+ sn_logfile.o sn_resolv.o
+ DEP_FILES = sn_config.h ./libpcap/pcap.h sn_data.h sn_defines.h sn_plugins.h \
+@@ -26,7 +26,6 @@
+ @echo "Succesfull compilation..."
sniffit: $(SNIFFIT) $(DEP_FILES)
-- cd libpcap-0.3; make; cd ..
-+ #cd libpcap-0.3; make; cd ..
+- cd libpcap; make; cd ..
$(CC) $(EXE_FLAG) $(SNIFFIT) $(EXE_OBJ) $(EXE_OPT) $(LIBS) $(DEFS) $(OS_OPT)
strip sniffit
diff --git a/net/sniffit/files/patch-02 b/net/sniffit/files/patch-02
index 868d5b939b26..88c5b1fb01df 100644
--- a/net/sniffit/files/patch-02
+++ b/net/sniffit/files/patch-02
@@ -1,35 +1,11 @@
---- sniffit.0.3.5.c.orig Fri Apr 18 02:33:58 1997
-+++ sniffit.0.3.5.c Fri Apr 3 20:44:10 1998
-@@ -411,11 +411,22 @@
- proto=unwrap_packet(sp, info);
- if(proto == NO_IP) return DONT_EXAMINE; /* no use in trying */
- if(proto == NO_IP_4) return DONT_EXAMINE; /* no use in trying */
-+ if(proto == CORRUPT_IP)
-+ {
-+ printf("Suspicious Packet detected... (Split header)\n");
-+ return DONT_EXAMINE;
-+ }
+--- sn_resolv.c.orig Thu Jul 16 09:17:10 1998
++++ sn_resolv.c Sun Aug 16 23:25:58 1998
+@@ -2,6 +2,8 @@
+ /* - getaddrbyname: Godmar Back / Shudoh Kazuyuki */
- memcpy(&iphead,(sp+PROTO_HEAD),sizeof(struct IP_header));
- so=(unsigned char *)&(iphead.source);
- dest=(unsigned char *)&(iphead.destination);
+ #include "sn_defines.h"
++#include <sys/types.h>
++#include <netinet/in.h>
+ #include <netdb.h>
+ #include <arpa/inet.h>
-+ if(info->FRAG_nf!=0)
-+ {
-+ printf("Fragment Skipped...\n");
-+ return DONT_EXAMINE;
-+ }
-+
- if((proto==TCP)&&(PROTOCOLS&F_TCP))
- {
- #ifdef DEBUG_ONSCREEN
-@@ -1220,6 +1231,9 @@
- proto=unwrap_packet(sp, info);
- if(proto == NO_IP) return DONT_EXAMINE; /* no use in trying */
- if(proto == NO_IP_4) return DONT_EXAMINE; /* no use in trying */
-+ if(proto == CORRUPT_IP) return DONT_EXAMINE; /* no use in trying */
-+
-+ if(info->FRAG_nf!=0) return DONT_EXAMINE;
-
- (*IP_nr_of_packets)++;
- if(proto==ICMP)
diff --git a/net/sniffit/files/patch-03 b/net/sniffit/files/patch-03
index 363a4d6a9a24..cdae155e058d 100644
--- a/net/sniffit/files/patch-03
+++ b/net/sniffit/files/patch-03
@@ -1,8 +1,13 @@
---- sn_packetstructs.h.orig Fri Apr 18 02:33:58 1997
-+++ sn_packetstructs.h Fri Apr 3 20:41:08 1998
-@@ -48,4 +48,5 @@
- {
- int IP_len, TCP_len, ICMP_len, UDP_len; /* header lengths */
- int DATA_len;
-+ char FRAG_nf; /* not the first fragment */
- };
+--- sn_data.h.orig Sun Aug 16 23:29:35 1998
++++ sn_data.h Sun Aug 16 23:30:48 1998
+@@ -38,8 +38,8 @@
+ char *NETDEV[]={"ppp","ed"};
+ int HEADSIZE[]={4 ,14};
+ */
+-#define NETDEV_NR 1
+-char *NETDEV[]={"ed"};
++#define NETDEV_NR 6
++char *NETDEV[]={"fxp","de","ed","ppp","tun","lo"};
+ int HEADSIZE[]={14};
+ #endif
+