aboutsummaryrefslogtreecommitdiff
path: root/net/sobby/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-08 14:12:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-08 14:12:45 +0000
commit5dfab6a53197a739c0ebc4aa061fa34f5b669b4c (patch)
tree32b03ec4bf2e7bb8aa744f19961cb2002fcf7bc2 /net/sobby/Makefile
parent83c3b662a56a8041bee15b69668eb4b1b2897747 (diff)
downloadports-5dfab6a53197a739c0ebc4aa061fa34f5b669b4c.tar.gz
ports-5dfab6a53197a739c0ebc4aa061fa34f5b669b4c.zip
- Update to 0.4.1
- Fix depen problems on pointyhat :) PR: ports/104238 Submitted by: Antoine Beaupre <anarcat@koumbit.org> Approved by: Andreas Kohn on irc
Notes
Notes: svn path=/head/; revision=176814
Diffstat (limited to 'net/sobby/Makefile')
-rw-r--r--net/sobby/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/sobby/Makefile b/net/sobby/Makefile
index 02d044fd6176..95fb91249be9 100644
--- a/net/sobby/Makefile
+++ b/net/sobby/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sobby
-PORTVERSION= 0.3.0
+PORTVERSION= 0.4.1
CATEGORIES= net
MASTER_SITES= http://releases.0x539.de/sobby/
@@ -15,9 +15,13 @@ COMMENT= A standalone obby server
LIB_DEPENDS= net6:${PORTSDIR}/net/net6 \
obby:${PORTSDIR}/devel/obby \
+ xml++:${PORTSDIR}/textproc/libxml++26 \
sigc++-2.0:${PORTSDIR}/devel/libsigc++20 \
glibmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
+MAN1= sobby.1
+MANCOMPRESSED= no
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
@@ -29,4 +33,8 @@ PLIST_FILES= bin/sobby
IGNORE= some dependencies does not run on FreeBSD < 5.x
.endif
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sobby ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sobby.1 ${PREFIX}/man/man1
+
.include <bsd.port.post.mk>