aboutsummaryrefslogtreecommitdiff
path: root/net/sobby/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-04-02 09:42:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-04-02 09:42:48 +0000
commite4309c5507f2d646c711365ed8abcf9dc8729d8a (patch)
tree78e5e49a7f8d762e5078b44b18009481a7c461f5 /net/sobby/Makefile
parent1230e1f721bfd46aa893e3c45c593c42e9ac2ef2 (diff)
downloadports-e4309c5507f2d646c711365ed8abcf9dc8729d8a.tar.gz
ports-e4309c5507f2d646c711365ed8abcf9dc8729d8a.zip
Chase a bunch of failures after libsigc++20 update
New libsigc++20 requires c++11 (it exposes c++11) so explicitly use -std=c++11 where needed. Mark as broken a bunch of ports which are not c++11 compatible
Notes
Notes: svn path=/head/; revision=437539
Diffstat (limited to 'net/sobby/Makefile')
-rw-r--r--net/sobby/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net/sobby/Makefile b/net/sobby/Makefile
index dbd978dab33d..c8b782bbae80 100644
--- a/net/sobby/Makefile
+++ b/net/sobby/Makefile
@@ -17,14 +17,12 @@ LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
libnet6.so:net/net6 \
libxml++-2.6.so:textproc/libxml++26
-USES= pkgconfig
+USES= localbase pkgconfig compiler:c++11-lang
+USE_CXXSTD= c++11
USE_GNOME= glibmm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-zeroconf
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
.include <bsd.port.mk>