aboutsummaryrefslogtreecommitdiff
path: root/net/spoofer
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-09 18:25:47 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-09 18:25:47 +0000
commit449c3a0fab051c34890caf335fc70b0b45effb3c (patch)
tree1380dcb7071e92598289082666486848d023e98a /net/spoofer
parent2ee9656cbbbbaa04df675a4e4896bf38e01ca91c (diff)
downloadports-449c3a0fab051c34890caf335fc70b0b45effb3c.tar.gz
ports-449c3a0fab051c34890caf335fc70b0b45effb3c.zip
Convert to options helper
- Move USES=qt:5 to GUI option: users with GUI disabled do not need this - Add USES=gl Submitted by: sunpoet (myself) Approved by: Matthew Luckie <mjl@luckie.org.nz> (maintainer)
Notes
Notes: svn path=/head/; revision=506301
Diffstat (limited to 'net/spoofer')
-rw-r--r--net/spoofer/Makefile27
1 files changed, 9 insertions, 18 deletions
diff --git a/net/spoofer/Makefile b/net/spoofer/Makefile
index 40467671db65..d5f6c7162638 100644
--- a/net/spoofer/Makefile
+++ b/net/spoofer/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= protoc:devel/protobuf
LIB_DEPENDS= libprotobuf-lite.so:devel/protobuf
RUN_DEPENDS= scamper:net/scamper
-USES= compiler:c++11-lib qt:5
+USES= compiler:c++11-lib
CONFIGURE_ARGS= --disable-development --with-protobuf=${LOCALBASE}
GNU_CONFIGURE= yes
@@ -27,29 +27,20 @@ OPTIONS_DEFINE= DOCS GUI
OPTIONS_DEFAULT=GUI
OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+GUI_CONFIGURE_ENABLE= manager
+GUI_USE= GL=gl QT=buildtools_build,qmake_build,core,network,gui,widgets
+GUI_USES= gl qt:5
+GUI_VARS= USE_RC_SUBR=${PORTNAME}
-.if ${PORT_OPTIONS:MGUI}
-USE_QT= buildtools_build qmake_build core network gui widgets
-USE_GL+= gl
-USE_RC_SUBR= ${PORTNAME}
-.else
-CONFIGURE_ARGS+= --disable-manager
-.endif
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-post-install:
-.if ${PORT_OPTIONS:MGUI}
+do-install-GUI-on:
.for r in 16 32 48 64 128 256
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${r}x${r}/apps
${INSTALL_DATA} ${WRKSRC}/icons/spoofer${r}.png \
${STAGEDIR}${PREFIX}/share/icons/hicolor/${r}x${r}/apps/spoofer.png
.endfor
-.endif
-
-do-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
.include <bsd.port.mk>