aboutsummaryrefslogtreecommitdiff
path: root/net/spread
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-02 18:21:05 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-02 18:21:05 +0000
commit0aad97bb5c24e162fa1f0e0fa87c8654f738ff52 (patch)
tree59a0148ef943ecb5bc12a830cc669c801d3c91f8 /net/spread
parent9046e7300f8c066998aad575e838180bdf83371e (diff)
downloadports-0aad97bb5c24e162fa1f0e0fa87c8654f738ff52.tar.gz
ports-0aad97bb5c24e162fa1f0e0fa87c8654f738ff52.zip
- Convert to new perl framework
Notes
Notes: svn path=/head/; revision=324171
Diffstat (limited to 'net/spread')
-rw-r--r--net/spread/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/net/spread/Makefile b/net/spread/Makefile
index 7f586611389b..dfbec48f6917 100644
--- a/net/spread/Makefile
+++ b/net/spread/Makefile
@@ -45,8 +45,10 @@ MAN3= libsp.3 SP_connect.3 SP_disconnect.3 SP_equal_group_ids.3 \
.include <bsd.port.pre.mk>
-# bsd.port.mk doesn't allow us to use GNU_CONFIGURE and PERL_CONFIGURE together.
-PERL_CONFIGURE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" PREFIX="${PREFIX}" \
+USES= perl5
+USE_PERL5= configure
+USES= perl5
+USE_PERL5= configure
INSTALLPRIVLIB="${PREFIX}/lib" INSTALLARCHLIB="${PREFIX}/lib"
_MANPAGES+= ${PREFIX}/lib/perl5/${PERL_VER}/man/man3/Spread.3
@@ -57,7 +59,8 @@ post-configure:
post-build:
@cd ${WRKSRC}/perl/Spread && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./Makefile.PL ${PERL_CONFIGURE_ARGS}
+USES= perl5
+USE_PERL5= configure
@cd ${WRKSRC}/perl/Spread && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
@cd ${WRKSRC}/perl/Spread && ${MAKE}