aboutsummaryrefslogtreecommitdiff
path: root/net/spread
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-05-20 06:03:04 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-05-20 06:03:04 +0000
commitaa64a516608801a751cff7155b12de0f8e960697 (patch)
tree3b86e7398be34956e9bf01cacd2e33886c058faa /net/spread
parent0cfaf75af537354fa66ed2357abf5ec83da6e494 (diff)
downloadports-aa64a516608801a751cff7155b12de0f8e960697.tar.gz
ports-aa64a516608801a751cff7155b12de0f8e960697.zip
net/spread: unbreak, support staging
- update master sites (maintained by submitter) - remove broken and deprecated - pass maintainership to submitter - support staging PR: 188853 Submitted by: C Hutchinson <portmaster@bsdforge.com>
Notes
Notes: svn path=/head/; revision=354596
Diffstat (limited to 'net/spread')
-rw-r--r--net/spread/Makefile47
-rw-r--r--net/spread/pkg-descr4
-rw-r--r--net/spread/pkg-plist19
3 files changed, 35 insertions, 35 deletions
diff --git a/net/spread/Makefile b/net/spread/Makefile
index b051e614eca7..39e50c972795 100644
--- a/net/spread/Makefile
+++ b/net/spread/Makefile
@@ -5,19 +5,14 @@ PORTNAME= spread
PORTVERSION= 3.17.4
PORTREVISION= 2
CATEGORIES= net perl5
-MASTER_SITES= http://www.edu-linux.org/down/
+MASTER_SITES= http://bsdforge.com/projects/source/apache2/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= portmaster@bsdforge.com
COMMENT= The Spread Group Communication System, a network toolkit
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-10
-
MAKE_JOBS_UNSAFE= yes
-PORTSCOUT= limit:^3
-
GNU_CONFIGURE= yes
USES= perl5
USE_RC_SUBR= spread
@@ -35,14 +30,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}
PKGMESSAGE= ${WRKSRC}/license.txt
PORTDOCS= Readme.txt LICENSE
HEADERFILES= sp_func.h sp_func.h sp_events.h
-MAN1= spflooder.1 spmonitor.1 spread.1 sptuser.1 spuser.1
-MAN3= libsp.3 SP_connect.3 SP_disconnect.3 SP_equal_group_ids.3 \
- SP_error.3 SP_join.3 SP_leave.3 \
- SP_multicast.3 SP_multigroup_multicast.3 \
- SP_multigroup_scat_multicast.3 SP_poll.3 SP_receive.3 \
- SP_scat_multicast.3 SP_scat_receive.3
-NO_STAGE= yes
.include <bsd.port.pre.mk>
# bsd.port.mk doesn't allow us to use GNU_CONFIGURE and PERL_CONFIGURE together.
@@ -64,29 +52,26 @@ post-build:
post-install:
.for f in ${HEADERFILES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/include
.endfor
${INSTALL_DATA} ${WRKSRC}/sample.spread.conf \
- ${PREFIX}/etc/spread.conf.sample
-.if !exists(${PREFIX}/etc/${PORTNAME}.conf)
+ ${STAGEDIR}${PREFIX}/etc/spread.conf.sample
+.if !exists(${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf)
${INSTALL_DATA} ${WRKSRC}/sample.spread.conf \
- ${PREFIX}/etc/${PORTNAME}.conf
+ ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf
.endif
${INSTALL_DATA} ${WRKSRC}/sample.spread.access_ip \
- ${PREFIX}/etc/spread.access_ip.sample
-.if !exists(${PREFIX}/etc/spread.access_ip)
+ ${STAGEDIR}${PREFIX}/etc/spread.access_ip.sample
+.if !exists(${STAGEDIR}${PREFIX}/etc/spread.access_ip)
${INSTALL_DATA} ${WRKSRC}/sample.spread.access_ip \
- ${PREFIX}/etc/spread.access_ip
-.endif
- (cd ${WRKSRC}/perl/Spread && ${MAKE} install)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/perl/Spread/test.pl ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Readme.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/license.txt ${DOCSDIR}/LICENSE
+ ${STAGEDIR}${PREFIX}/etc/spread.access_ip
.endif
- @${INSTALL} -m 750 -o ${USERS} -g ${GROUPS} -d ${RUNDIR}
- @${CAT} ${PKGMESSAGE}
+ (cd ${WRKSRC}/perl/Spread && ${MAKE} PREFIX=${STAGEDIR}${PREFIX} install)
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/perl/Spread/test.pl ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Readme.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/license.txt ${STAGEDIR}${DOCSDIR}/LICENSE
+ ${INSTALL} -m 750 -d ${STAGEDIR}${RUNDIR}
.include <bsd.port.post.mk>
diff --git a/net/spread/pkg-descr b/net/spread/pkg-descr
index 6ceac607d8e7..0ce37a0d05fc 100644
--- a/net/spread/pkg-descr
+++ b/net/spread/pkg-descr
@@ -1,7 +1,3 @@
-Copyright (c) 1993-2002 Spread Concepts LLC. All rights reserved.
-This product uses software developed by Spread Concepts LLC for use in the
-Spread toolkit. For more information about Spread see http://www.spread.org/
-
Spread is a toolkit and daemon that provide multicast and group communications
support to applications across local and wide area networks. Spread is designed
to make it easy to write groupware, networked multimedia, reliable server, and
diff --git a/net/spread/pkg-plist b/net/spread/pkg-plist
index 7c1fc73bac2c..5ed3fa2d27a5 100644
--- a/net/spread/pkg-plist
+++ b/net/spread/pkg-plist
@@ -17,6 +17,25 @@ lib/libspread.so.1
lib/libtspread.a
lib/libtspread.so
lib/libtspread.so.1
+man/man1/spflooder.1.gz
+man/man1/spmonitor.1.gz
+man/man1/spread.1.gz
+man/man1/sptuser.1.gz
+man/man1/spuser.1.gz
+man/man3/libsp.3.gz
+man/man3/SP_connect.3.gz
+man/man3/SP_disconnect.3.gz
+man/man3/SP_equal_group_ids.3.gz
+man/man3/SP_error.3.gz
+man/man3/SP_join.3.gz
+man/man3/SP_leave.3.gz
+man/man3/SP_multicast.3.gz
+man/man3/SP_multigroup_multicast.3.gz
+man/man3/SP_multigroup_scat_multicast.3.gz
+man/man3/SP_poll.3.gz
+man/man3/SP_receive.3.gz
+man/man3/SP_scat_multicast.3.gz
+man/man3/SP_scat_receive.3.gz
%%SITE_PERL%%/%%PERL_ARCH%%/Spread.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/Spread.bs