aboutsummaryrefslogtreecommitdiff
path: root/net/spserver/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-03-10 12:43:49 +0000
committerRene Ladan <rene@FreeBSD.org>2014-03-10 12:43:49 +0000
commita935cff705e744c5cc1d6be3c72d055e5f435955 (patch)
treec96f1135b827f2a0522af3f45b0d5e06950da7c6 /net/spserver/Makefile
parent5111f8553dc31abd7088022fbffd14c467fbeed3 (diff)
downloadports-a935cff705e744c5cc1d6be3c72d055e5f435955.tar.gz
ports-a935cff705e744c5cc1d6be3c72d055e5f435955.zip
Remove commented-out support for expired security/xyssl
Submitted by: johans Approved by: portmgr (infrastructure blanket)
Notes
Notes: svn path=/head/; revision=347752
Diffstat (limited to 'net/spserver/Makefile')
-rw-r--r--net/spserver/Makefile17
1 files changed, 1 insertions, 16 deletions
diff --git a/net/spserver/Makefile b/net/spserver/Makefile
index 642ea2832490..b33242d62247 100644
--- a/net/spserver/Makefile
+++ b/net/spserver/Makefile
@@ -20,8 +20,7 @@ ALL_TARGET= all build_openssl
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= GNUTLS
-# MATRIXSSL "Enable matrixssl support" off \
-# XYSSL "Enable xyssl support" off
+# MATRIXSSL "Enable matrixssl support" off
.include <bsd.port.options.mk>
@@ -41,14 +40,6 @@ PLIST_SUB+= WITH_GNUTLS=""
PLIST_SUB+= WITH_GNUTLS="@comment "
.endif
-.if ${PORT_OPTIONS:MXYSSL}
-BUILD_DEPENDS= ${LOCALBASE}/lib/libxyssl.a:${PORTSDIR}/security/xyssl
-ALL_TARGET+= build_xyssl
-PLIST_SUB+= WITH_XYSSL=""
-.else
-PLIST_SUB+= WITH_XYSSL="@comment "
-.endif
-
post-patch:
${SED} -i -E 's,%PREFIX%,${PREFIX},g' ${WRKSRC}/spserver/Makefile
${SED} -i -E 's,%PREFIX%,${PREFIX},g' ${WRKSRC}/gnutls/Makefile
@@ -77,10 +68,4 @@ do-install:
@${LN} -s ${PREFIX}/lib/libspmatrixssl.so.1 ${STAGEDIR}/${PREFIX}/lib/libspmatrixssl.so
.endif
-.if ${PORT_OPTIONS:MXYSSL}
- @${INSTALL} ${WRKSRC}/xyssl/spxyssl.hpp ${STAGEDIR}/${PREFIX}/include/spserver
- @${INSTALL} ${WRKSRC}/xyssl/libspxyssl.so ${STAGEDIR}/${PREFIX}/lib/libspxyssl.so.1
- @${LN} -s ${PREFIX}/lib/libspxyssl.so.1 ${STAGEDIR}/${PREFIX}/lib/libspxyssl.so
-.endif
-
.include <bsd.port.mk>