aboutsummaryrefslogtreecommitdiff
path: root/net/syncthing
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2022-05-08 15:05:07 +0000
committerDimitry Andric <dim@FreeBSD.org>2022-05-08 15:05:07 +0000
commit2ff27291417d9a79b9c43d6d128817e5ec465a17 (patch)
tree259bfbb5040333f2e627302de340d15fe0e68a8f /net/syncthing
parenta26f3e34543c53e4624137935e897fb779c05170 (diff)
downloadports-2ff27291417d9a79b9c43d6d128817e5ec465a17.tar.gz
ports-2ff27291417d9a79b9c43d6d128817e5ec465a17.zip
net/syncthing: Fix broken build and upgrade to 1.20.1
After lang/go was updated to 1.18, net/syncthing failed to build under poudriere, with errors similar to: vendor/github.com/marten-seemann/qtls-go1-18/cipher_suites.go:143:43: undeclared name: any (requires version go1.18 or later) This is because the packaged vendor libraries in the upstream tarball don't work with go 1.18. Fix this by using USES=go:modules and changing the build commands. Also, upgrade to 1.20.1. PR: 262808 Reported by: Oscar Carlsson <oscar@spindel.tax> Approved by: maintainer timeout (2 weeks) Submitted by: dmgk MFH: 2022Q2
Diffstat (limited to 'net/syncthing')
-rw-r--r--net/syncthing/Makefile13
-rw-r--r--net/syncthing/distinfo6
2 files changed, 9 insertions, 10 deletions
diff --git a/net/syncthing/Makefile b/net/syncthing/Makefile
index 2a8025f96c71..1d8d51b424d6 100644
--- a/net/syncthing/Makefile
+++ b/net/syncthing/Makefile
@@ -1,7 +1,6 @@
PORTNAME= syncthing
-PORTVERSION= 1.19.1
+PORTVERSION= 1.20.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://github.com/syncthing/syncthing/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}-source-${DISTVERSIONPREFIX}${PORTVERSION}
@@ -13,7 +12,7 @@ COMMENT= Encrypted file sync tool
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/${PORTNAME}/LICENSE
-USES= cpe go
+USES= cpe go:modules
USE_RC_SUBR= syncthing syncthing-discosrv syncthing-relaysrv syncthing-relaypoolsrv
@@ -37,10 +36,10 @@ NO_WRKSUBDIR= yes
do-build:
@( cd ${WRKSRC}/${PORTNAME} ; \
- ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOFLAGS="-mod=vendor" go run build.go -version v${PORTVERSION} -no-upgrade build ; \
- ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOFLAGS="-mod=vendor" go run build.go -version v${PORTVERSION} -no-upgrade build stdiscosrv ; \
- ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOFLAGS="-mod=vendor" go run build.go -version v${PORTVERSION} -no-upgrade build strelaysrv ; \
- ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOFLAGS="-mod=vendor" go run build.go -version v${PORTVERSION} -no-upgrade build strelaypoolsrv ; \
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} GOPROXY=off ${GO_CMD} run build.go -version v${PORTVERSION} -no-upgrade build ; \
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} GOPROXY=off ${GO_CMD} run build.go -version v${PORTVERSION} -no-upgrade build stdiscosrv; \
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} GOPROXY=off ${GO_CMD} run build.go -version v${PORTVERSION} -no-upgrade build strelaysrv; \
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} GOPROXY=off ${GO_CMD} run build.go -version v${PORTVERSION} -no-upgrade build strelaypoolsrv; \
)
do-install:
diff --git a/net/syncthing/distinfo b/net/syncthing/distinfo
index ac9d17da9b5a..34261f80f008 100644
--- a/net/syncthing/distinfo
+++ b/net/syncthing/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1647122497
-SHA256 (syncthing-source-v1.19.1.tar.gz) = ffc5ec2f232314122a216884f63a48eea7c8739f9779e249be1f4776d7a55127
-SIZE (syncthing-source-v1.19.1.tar.gz) = 13216635
+TIMESTAMP = 1651934802
+SHA256 (syncthing-source-v1.20.1.tar.gz) = a88fabaea11a8df5cc134075c37dc87f1fb33b48d3d8afb1dc8ea11b3c0925bc
+SIZE (syncthing-source-v1.20.1.tar.gz) = 13184830