aboutsummaryrefslogtreecommitdiff
path: root/net/syndication/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 18:17:02 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 18:17:02 +0000
commit4e7e29a51e1bfd07c0f3d70b9511ca1982a378a6 (patch)
treeec729bf6c4038e10d1da0b36034c85bf35c04a08 /net/syndication/Makefile
parent0e0a4e18336778a565d528571c6d8bbc58e6c1f1 (diff)
downloadports-4e7e29a51e1bfd07c0f3d70b9511ca1982a378a6.tar.gz
ports-4e7e29a51e1bfd07c0f3d70b9511ca1982a378a6.zip
New ports: net-p2p/ktorrent, net-p2p/libktorrent, net/syndication
This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4. This one is a bit ugly: move libktorrent and ktorrent-kde4 out of the way and readd the new ones in one go, to not have to touch the same MOVED lines in a short time span. Also this adds a very stripped down version of the desktuils/kdepim metaport, which will get more and more dependencies added shortly.
Notes
Notes: svn path=/head/; revision=466980
Diffstat (limited to 'net/syndication/Makefile')
-rw-r--r--net/syndication/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/net/syndication/Makefile b/net/syndication/Makefile
new file mode 100644
index 000000000000..709df8b37f79
--- /dev/null
+++ b/net/syndication/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= syndication
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= net kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE RSS feed handling library
+
+LICENSE= LGPL21
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= codecs config coreaddons ecm kio service
+USE_QT5= core gui xml \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+
+.include <bsd.port.mk>