aboutsummaryrefslogtreecommitdiff
path: root/net/tcpproxy/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-07 18:44:30 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-07 18:44:30 +0000
commit643ae650a14b1f2d924ca3a33a9d26d87fd189f1 (patch)
tree8f5bf473e5fc908f593f3490e900ba35ad05dd2e /net/tcpproxy/Makefile
parentd3657c4a8cc0fae434ea289551ac05f709dda4df (diff)
downloadports-643ae650a14b1f2d924ca3a33a9d26d87fd189f1.tar.gz
ports-643ae650a14b1f2d924ca3a33a9d26d87fd189f1.zip
- Update from 1.0 to 1.1 [1]
- Remove the indefinite article from COMMENT - Convert USE_GMAKE to USES - Add stage support PR: ports/182788 Submitted by: Alexander Hausner <alex@hugo.bmg.gv.at> (maintainer) [1] Approved by: wg/culot (mentors, implicit)
Notes
Notes: svn path=/head/; revision=329723
Diffstat (limited to 'net/tcpproxy/Makefile')
-rw-r--r--net/tcpproxy/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/net/tcpproxy/Makefile b/net/tcpproxy/Makefile
index 6690115c53bd..9b982e0219fe 100644
--- a/net/tcpproxy/Makefile
+++ b/net/tcpproxy/Makefile
@@ -2,35 +2,32 @@
# $FreeBSD$
PORTNAME= tcpproxy
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.1
CATEGORIES= net
MASTER_SITES= http://www.spreadspace.org/tcpproxy/releases/ \
http://alex.bmg.gv.at/programs/
MAINTAINER= alex@hugo.bmg.gv.at
-COMMENT= A simple TCP connection proxy for IPv4 and IPv6
+COMMENT= Simple TCP connection proxy for IPv4 and IPv6
BUILD_DEPENDS= ragel:${PORTSDIR}/devel/ragel
-USE_GMAKE= yes
+USES= gmake
HAS_CONFIGURE= yes
USERS= _tcpproxy
GROUPS= _tcpproxy
-MAN8= tcpproxy.8
-
USE_RC_SUBR= tcpproxy
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-PLIST_FILES= bin/tcpproxy etc/tcpproxy_sample.conf
+PLIST_FILES= bin/tcpproxy etc/tcpproxy_sample.conf \
+ man/man8/tcpproxy.8.gz
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/tcpproxy ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/contrib/example.conf ${PREFIX}/etc/tcpproxy_sample.conf
- ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/${MAN8} ${PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpproxy ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/contrib/example.conf ${STAGEDIR}${PREFIX}/etc/tcpproxy_sample.conf
+ ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/tcpproxy.8 ${STAGEDIR}${PREFIX}/man/man8
.include <bsd.port.mk>