aboutsummaryrefslogtreecommitdiff
path: root/net/tcpsg
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:44:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:44:51 +0000
commit698ced054ef40e7e6f875e17c1ccc6487e913649 (patch)
tree86a6a09063083d1cab096e3ea41d8b0865eef7e2 /net/tcpsg
parent5d824297fb72f7719603bab88c950c2263150191 (diff)
downloadports-698ced054ef40e7e6f875e17c1ccc6487e913649.tar.gz
ports-698ced054ef40e7e6f875e17c1ccc6487e913649.zip
add tcpsg 0.02
A simple TCP port forwarder PR: 44751 Submitted by: Michael L. Hostbaek <mich@freebsdcluster.org>
Notes
Notes: svn path=/head/; revision=70596
Diffstat (limited to 'net/tcpsg')
-rw-r--r--net/tcpsg/Makefile33
-rw-r--r--net/tcpsg/distinfo1
-rw-r--r--net/tcpsg/files/patch-tcpsg.c21
-rw-r--r--net/tcpsg/pkg-comment1
-rw-r--r--net/tcpsg/pkg-descr9
-rw-r--r--net/tcpsg/pkg-plist5
6 files changed, 70 insertions, 0 deletions
diff --git a/net/tcpsg/Makefile b/net/tcpsg/Makefile
new file mode 100644
index 000000000000..08a1fa71fd35
--- /dev/null
+++ b/net/tcpsg/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: tcpsg
+# Date created: Tue Oct 30, 2002
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpsg
+PORTVERSION= 0.0.2
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mich@freebsdcluster.org
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/tcpsg.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/tcpsg.conf ${PREFIX}/etc/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/tcpsg.ctl ${DOCSDIR}/tcpsg.ctl
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/tcpsg/distinfo b/net/tcpsg/distinfo
new file mode 100644
index 000000000000..5e7b38956c2d
--- /dev/null
+++ b/net/tcpsg/distinfo
@@ -0,0 +1 @@
+MD5 (tcpsg-0.0.2.tar.gz) = 796c4abceb14b7fc1447bad7397aa630
diff --git a/net/tcpsg/files/patch-tcpsg.c b/net/tcpsg/files/patch-tcpsg.c
new file mode 100644
index 000000000000..8c50333a83a4
--- /dev/null
+++ b/net/tcpsg/files/patch-tcpsg.c
@@ -0,0 +1,21 @@
+--- tcpsg.c.orig Wed Oct 30 13:14:39 2002
++++ tcpsg.c Wed Oct 30 13:41:13 2002
+@@ -39,8 +39,8 @@
+
+ /* Network Headers */
+ #include <sys/socket.h>
+-#include <arpa/inet.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <netdb.h>
+
+ /*
+@@ -229,7 +229,7 @@
+ int set_config()
+ {
+ int i,j;
+- i=read_config("/etc/tcpsg.conf");
++ i=read_config("%%PREFIX%%/etc/tcpsg.conf");
+ if (i==0)
+ {
+ for (i=0;i<main_opt.num_servers;i++)
diff --git a/net/tcpsg/pkg-comment b/net/tcpsg/pkg-comment
new file mode 100644
index 000000000000..ab1752febd40
--- /dev/null
+++ b/net/tcpsg/pkg-comment
@@ -0,0 +1 @@
+A simple TCP port forwarder
diff --git a/net/tcpsg/pkg-descr b/net/tcpsg/pkg-descr
new file mode 100644
index 000000000000..72f74a987c93
--- /dev/null
+++ b/net/tcpsg/pkg-descr
@@ -0,0 +1,9 @@
+TCPSG is just a simple TCP port forwarder designed to distribute a service
+like a virtual server. It can be used to protect servers using the port
+forwarder to receive requests.
+
+AUTHOR: Juan Fajardo <jfajardo@unillanos.edu.co>
+WWW: http://tcpsg.sourceforge.net/
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/net/tcpsg/pkg-plist b/net/tcpsg/pkg-plist
new file mode 100644
index 000000000000..da540fb3d5ae
--- /dev/null
+++ b/net/tcpsg/pkg-plist
@@ -0,0 +1,5 @@
+sbin/tcpsg
+etc/tcpsg.conf
+%%PORTDOCS%%share/doc/tcpsg/README
+%%PORTDOCS%%share/doc/tcpsg/tcpsg.ctl
+%%PORTDOCS%%@dirrm share/doc/tcpsg